4.9-P-builds update site not available again

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

4.9-P-builds update site not available again

Philippe Cadé
Dear all,

The following update site seems to not be available again: https://download.eclipse.org/eclipse/updates/4.9-P-builds

We are still using Eclipse 4.9 with the Java 11 support patch and having this update site is important for us.

We had talked about this before, see  https://www.eclipse.org/lists/jdt-dev/msg01155.html
and the update site was then restored.

Was it removed again?

Thanks for looking into this

Kind regards
Philippe

_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: 4.9-P-builds update site not available again

Sravan K Lakkimsetti

Hi,

 

Java 11 support is available from 4.10 onwards,. This patch site is applicable for 4.9 only and 4.9 is out of support now. Is it possible for you to upgrade to later versions?

We are in the process of delivering java 14 support shortly. In this regard we started cleaning up old outdated repos.

 

Thanks

Sravan

 

 

From: Philippe Cadé <[hidden email]>
Sent: 13 March 2020 20:16
To: Eclipse JDT general developers list. <[hidden email]>
Subject: [EXTERNAL] [jdt-dev] 4.9-P-builds update site not available again

 

Dear all,

The following update site seems to not be available again: https://download.eclipse.org/eclipse/updates/4.9-P-builds

 

We are still using Eclipse 4.9 with the Java 11 support patch and having this update site is important for us.

We had talked about this before, see  https://www.eclipse.org/lists /jdt-dev/msg01155.html

and the update site was then restored.

 

Was it removed again?

 

Thanks for looking into this

 

Kind regards

Philippe



_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: 4.9-P-builds update site not available again

Philippe Cadé
Hello Sravan,

As I said last time, we are not able to move to 4.10 because our code doesn't compile with that version due to split packages issues. This code is for one of our stable branches that we need to support for another couple of years. Our policy only allows bug fixes on this branch so changing the compiler version is not possible.

We are using Eclipse 4.13 for our newest code where we have solved the split package issues and there everything is fine.

We would really appreciate if you could put this update site up again.

I imagine this situation will affect all the early adapters of Java 11.

Thank you for your consideration.

Philippe



On Fri, Mar 13, 2020 at 4:24 PM Sravan K Lakkimsetti <[hidden email]> wrote:

Hi,

 

Java 11 support is available from 4.10 onwards,. This patch site is applicable for 4.9 only and 4.9 is out of support now. Is it possible for you to upgrade to later versions?

We are in the process of delivering java 14 support shortly. In this regard we started cleaning up old outdated repos.

 

Thanks

Sravan

 

 

From: Philippe Cadé <[hidden email]>
Sent: 13 March 2020 20:16
To: Eclipse JDT general developers list. <[hidden email]>
Subject: [EXTERNAL] [jdt-dev] 4.9-P-builds update site not available again

 

Dear all,

The following update site seems to not be available again: https://download.eclipse.org/eclipse/updates/4.9-P-builds

 

We are still using Eclipse 4.9 with the Java 11 support patch and having this update site is important for us.

We had talked about this before, see  https://www.eclipse.org/lists /jdt-dev/msg01155.html

and the update site was then restored.

 

Was it removed again?

 

Thanks for looking into this

 

Kind regards

Philippe


_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev

_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: 4.9-P-builds update site not available again

Gunnar Wagenknecht
Hi Philippe,

> As I said last time, we are not able to move to 4.10 because our code doesn't compile with that version due to split packages issues. This code is for one of our stable branches that we need to support for another couple of years. Our policy only allows bug fixes on this branch so changing the compiler version is not possible.
>
> We are using Eclipse 4.13 for our newest code where we have solved the split package issues and there everything is fine.
>
> We would really appreciate if you could put this update site up again.

The old versions are still available here:
https://archive.eclipse.org/eclipse/downloads/drops4/R-4.9-201809060745/

If you are relying on this for another couple of years, I highly recommend setting up an internal mirror that you use in your CI/CD pipeline. We do the same. Depending on how critical this is to your business, you might want to consider setting up a branch with back ports of important fixes.

There are consulting companies available in case you need help:
https://www.eclipse.org/membership/exploreMembership.php

Please be mindful about the limited resources of teams working on open source. They need to focus on the future and innovation. They shouldn't spend time in maintaining legacy.

Thanks!

-Gunnar

--
Gunnar Wagenknecht
[hidden email], http://guw.io/


_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: 4.9-P-builds update site not available again

Philippe Cadé
Dear all,

Gunnar, I fail to find the patches for Java 11 in the link you provided. This is what is interesting to me, not the base 4.9 version.

I see now more and more that it is dangerous for us to rely on some external software sites that could disappear from one day to the other; we will indeed have to put some measures in place to protect us from that. I also understand that the open source community wants to move forward.

However I don't always understand the logic of when to remove things. Why would a patch to support Java 8 on Eclipse 4.3 be still available today [1] but not a patch to support Java 11 on 4.9?

Philippe


On Mon, Mar 16, 2020 at 10:30 AM Gunnar Wagenknecht <[hidden email]> wrote:
Hi Philippe,

> As I said last time, we are not able to move to 4.10 because our code doesn't compile with that version due to split packages issues. This code is for one of our stable branches that we need to support for another couple of years. Our policy only allows bug fixes on this branch so changing the compiler version is not possible.
>
> We are using Eclipse 4.13 for our newest code where we have solved the split package issues and there everything is fine.
>
> We would really appreciate if you could put this update site up again.

The old versions are still available here:
https://archive.eclipse.org/eclipse/downloads/drops4/R-4.9-201809060745/

If you are relying on this for another couple of years, I highly recommend setting up an internal mirror that you use in your CI/CD pipeline. We do the same. Depending on how critical this is to your business, you might want to consider setting up a branch with back ports of important fixes.

There are consulting companies available in case you need help:
https://www.eclipse.org/membership/exploreMembership.php

Please be mindful about the limited resources of teams working on open source. They need to focus on the future and innovation. They shouldn't spend time in maintaining legacy.

Thanks!

-Gunnar

--
Gunnar Wagenknecht
[hidden email], http://guw.io/


_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev

_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: 4.9-P-builds update site not available again

Gunnar Wagenknecht
> Gunnar, I fail to find the patches for Java 11 in the link you provided. This is what is interesting to me, not the base 4.9 version.

Sorry, I misunderstood. I thought you were looking for the 4.9 drops.

I believe the branch for the JDT 4.9 Java 11 work is this one:
https://git.eclipse.org/c/jdt/eclipse.jdt.core.git/?h=BETA_JAVA11

Do you know which P2018... version you are looking for? If you have a specific tag you should also be able to retrieve the source as everything is properly tagged.

> However I don't always understand the logic of when to remove things. Why would a patch to support Java 8 on Eclipse 4.3 be still available today [1] but not a patch to support Java 11 on 4.9?

It's a decision a project team does. It's uncommon to use archive.eclipse.org for beta artifacts, though. It's only intended for things that should be persisted forever - like releases. I believe no-one thought a beta patch feature would be critical to keep around.

-Gunnar
_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: 4.9-P-builds update site not available again

Philippe Cadé
Dear all,

Okay, we figured it out. We have now copied the necessary patch feature into our own internal software site.

Thanks everybody for the help.

Philippe

On Mon, Mar 16, 2020 at 6:12 PM Gunnar Wagenknecht <[hidden email]> wrote:
> Gunnar, I fail to find the patches for Java 11 in the link you provided. This is what is interesting to me, not the base 4.9 version.

Sorry, I misunderstood. I thought you were looking for the 4.9 drops.

I believe the branch for the JDT 4.9 Java 11 work is this one:
https://git.eclipse.org/c/jdt/eclipse.jdt.core.git/?h=BETA_JAVA11

Do you know which P2018... version you are looking for? If you have a specific tag you should also be able to retrieve the source as everything is properly tagged.

> However I don't always understand the logic of when to remove things. Why would a patch to support Java 8 on Eclipse 4.3 be still available today [1] but not a patch to support Java 11 on 4.9?

It's a decision a project team does. It's uncommon to use archive.eclipse.org for beta artifacts, though. It's only intended for things that should be persisted forever - like releases. I believe no-one thought a beta patch feature would be critical to keep around.

-Gunnar
_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev

_______________________________________________
jdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/jdt-dev