Api baseline update

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Api baseline update

Mark B
I was trying to update the api baseline, I changed CDT from 9.10 to 9.11
and platform from 4.14 to 4.15. However I have the following error:

Contains: Cannot complete the install because of a conflicting dependency.
Contains: Software being installed: C/C++ Arduino Tools
9.11.0.202001140305 (org.eclipse.cdt.arduino.feature.group
9.11.0.202001140305)
Contains: Software being installed: Template Engine Freemarker Support
(Java 11) 1.1.2.201911192140
(org.eclipse.tools.templates.freemarker.java11 1.1.2.201911192140)
Contains: Only one of the following can be installed at once:
Contains: Template Engine Freemarker Support (Java 11)
1.1.100.202001140305 (org.eclipse.tools.templates.freemarker.java11
1.1.100.202001140305)
Contains: Template Engine Freemarker Support (Java 11)
1.1.2.201911192140 (org.eclipse.tools.templates.freemarker.java11
1.1.2.201911192140)
Contains: Cannot satisfy dependency:
Contains: From: C/C++ Arduino Tools 9.11.0.202001140305
(org.eclipse.cdt.arduino.feature.group 9.11.0.202001140305)
Contains: To: org.eclipse.equinox.p2.iu;
org.eclipse.tools.templates.freemarker.java11
[1.1.100.202001140305,1.1.100.202001140305]

Is it problem related to my environment? I'm still using 2019-12.
_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Api baseline update

Alexander Fedorov
Hi Marco,

Where exactly do you have this problem? Are you trying to update
baseline .target locally and then use it?

Regards,
AF

21.03.2020 12:13, marco пишет:

> I was trying to update the api baseline, I changed CDT from 9.10 to
> 9.11 and platform from 4.14 to 4.15. However I have the following error:
>
> Contains: Cannot complete the install because of a conflicting
> dependency.
> Contains: Software being installed: C/C++ Arduino Tools
> 9.11.0.202001140305 (org.eclipse.cdt.arduino.feature.group
> 9.11.0.202001140305)
> Contains: Software being installed: Template Engine Freemarker Support
> (Java 11) 1.1.2.201911192140
> (org.eclipse.tools.templates.freemarker.java11 1.1.2.201911192140)
> Contains: Only one of the following can be installed at once:
> Contains: Template Engine Freemarker Support (Java 11)
> 1.1.100.202001140305 (org.eclipse.tools.templates.freemarker.java11
> 1.1.100.202001140305)
> Contains: Template Engine Freemarker Support (Java 11)
> 1.1.2.201911192140 (org.eclipse.tools.templates.freemarker.java11
> 1.1.2.201911192140)
> Contains: Cannot satisfy dependency:
> Contains: From: C/C++ Arduino Tools 9.11.0.202001140305
> (org.eclipse.cdt.arduino.feature.group 9.11.0.202001140305)
> Contains: To: org.eclipse.equinox.p2.iu;
> org.eclipse.tools.templates.freemarker.java11
> [1.1.100.202001140305,1.1.100.202001140305]
>
> Is it problem related to my environment? I'm still using 2019-12.
> _______________________________________________
> cdt-dev mailing list
> [hidden email]
> To unsubscribe from this list, visit
> https://www.eclipse.org/mailman/listinfo/cdt-dev
>

_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Api baseline update

Mark B
Yes, exactly.

Il 21/03/20 10:57, Alexander Fedorov ha scritto:

> Hi Marco,
>
> Where exactly do you have this problem? Are you trying to update
> baseline .target locally and then use it?
>
> Regards,
> AF
>
> 21.03.2020 12:13, marco пишет:
>> I was trying to update the api baseline, I changed CDT from 9.10 to
>> 9.11 and platform from 4.14 to 4.15. However I have the following error:
>>
>> Contains: Cannot complete the install because of a conflicting
>> dependency.
>> Contains: Software being installed: C/C++ Arduino Tools
>> 9.11.0.202001140305 (org.eclipse.cdt.arduino.feature.group
>> 9.11.0.202001140305)
>> Contains: Software being installed: Template Engine Freemarker Support
>> (Java 11) 1.1.2.201911192140
>> (org.eclipse.tools.templates.freemarker.java11 1.1.2.201911192140)
>> Contains: Only one of the following can be installed at once:
>> Contains: Template Engine Freemarker Support (Java 11)
>> 1.1.100.202001140305 (org.eclipse.tools.templates.freemarker.java11
>> 1.1.100.202001140305)
>> Contains: Template Engine Freemarker Support (Java 11)
>> 1.1.2.201911192140 (org.eclipse.tools.templates.freemarker.java11
>> 1.1.2.201911192140)
>> Contains: Cannot satisfy dependency:
>> Contains: From: C/C++ Arduino Tools 9.11.0.202001140305
>> (org.eclipse.cdt.arduino.feature.group 9.11.0.202001140305)
>> Contains: To: org.eclipse.equinox.p2.iu;
>> org.eclipse.tools.templates.freemarker.java11
>> [1.1.100.202001140305,1.1.100.202001140305]
>>
>> Is it problem related to my environment? I'm still using 2019-12.
>> _______________________________________________
>> cdt-dev mailing list
>> [hidden email]
>> To unsubscribe from this list, visit
>> https://www.eclipse.org/mailman/listinfo/cdt-dev
>>
>
> _______________________________________________
> cdt-dev mailing list
> [hidden email]
> To unsubscribe from this list, visit
> https://www.eclipse.org/mailman/listinfo/cdt-dev
_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Api baseline update

Alexander Fedorov
Let's discuss at https://bugs.eclipse.org/bugs/show_bug.cgi?id=561314, I
plan to provide a gerrit for it.

Regards,
AF

21.03.2020 12:59, marco пишет:

> Yes, exactly.
>
> Il 21/03/20 10:57, Alexander Fedorov ha scritto:
>> Hi Marco,
>>
>> Where exactly do you have this problem? Are you trying to update
>> baseline .target locally and then use it?
>>
>> Regards,
>> AF
>>
>> 21.03.2020 12:13, marco пишет:
>>> I was trying to update the api baseline, I changed CDT from 9.10 to
>>> 9.11 and platform from 4.14 to 4.15. However I have the following
>>> error:
>>>
>>> Contains: Cannot complete the install because of a conflicting
>>> dependency.
>>> Contains: Software being installed: C/C++ Arduino Tools
>>> 9.11.0.202001140305 (org.eclipse.cdt.arduino.feature.group
>>> 9.11.0.202001140305)
>>> Contains: Software being installed: Template Engine Freemarker
>>> Support (Java 11) 1.1.2.201911192140
>>> (org.eclipse.tools.templates.freemarker.java11 1.1.2.201911192140)
>>> Contains: Only one of the following can be installed at once:
>>> Contains: Template Engine Freemarker Support (Java 11)
>>> 1.1.100.202001140305 (org.eclipse.tools.templates.freemarker.java11
>>> 1.1.100.202001140305)
>>> Contains: Template Engine Freemarker Support (Java 11)
>>> 1.1.2.201911192140 (org.eclipse.tools.templates.freemarker.java11
>>> 1.1.2.201911192140)
>>> Contains: Cannot satisfy dependency:
>>> Contains: From: C/C++ Arduino Tools 9.11.0.202001140305
>>> (org.eclipse.cdt.arduino.feature.group 9.11.0.202001140305)
>>> Contains: To: org.eclipse.equinox.p2.iu;
>>> org.eclipse.tools.templates.freemarker.java11
>>> [1.1.100.202001140305,1.1.100.202001140305]
>>>
>>> Is it problem related to my environment? I'm still using 2019-12.
>>> _______________________________________________
>>> cdt-dev mailing list
>>> [hidden email]
>>> To unsubscribe from this list, visit
>>> https://www.eclipse.org/mailman/listinfo/cdt-dev
>>>
>>
>> _______________________________________________
>> cdt-dev mailing list
>> [hidden email]
>> To unsubscribe from this list, visit
>> https://www.eclipse.org/mailman/listinfo/cdt-dev
> _______________________________________________
> cdt-dev mailing list
> [hidden email]
> To unsubscribe from this list, visit
> https://www.eclipse.org/mailman/listinfo/cdt-dev

_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Api baseline update

Jonah Graham
Thank you Marco and Alexander for jumping on this. 

I have created the endgame issue for 9.12 - https://github.com/eclipse-cdt/cdt-infra/issues/27 - so feel free to check off items that get done. 

Jonah


~~~
Jonah Graham
Kichwa Coders
www.kichwacoders.com


On Sat, 21 Mar 2020 at 06:05, Alexander Fedorov <[hidden email]> wrote:
Let's discuss at https://bugs.eclipse.org/bugs/show_bug.cgi?id=561314, I
plan to provide a gerrit for it.

Regards,
AF

21.03.2020 12:59, marco пишет:
> Yes, exactly.
>
> Il 21/03/20 10:57, Alexander Fedorov ha scritto:
>> Hi Marco,
>>
>> Where exactly do you have this problem? Are you trying to update
>> baseline .target locally and then use it?
>>
>> Regards,
>> AF
>>
>> 21.03.2020 12:13, marco пишет:
>>> I was trying to update the api baseline, I changed CDT from 9.10 to
>>> 9.11 and platform from 4.14 to 4.15. However I have the following
>>> error:
>>>
>>> Contains: Cannot complete the install because of a conflicting
>>> dependency.
>>> Contains: Software being installed: C/C++ Arduino Tools
>>> 9.11.0.202001140305 (org.eclipse.cdt.arduino.feature.group
>>> 9.11.0.202001140305)
>>> Contains: Software being installed: Template Engine Freemarker
>>> Support (Java 11) 1.1.2.201911192140
>>> (org.eclipse.tools.templates.freemarker.java11 1.1.2.201911192140)
>>> Contains: Only one of the following can be installed at once:
>>> Contains: Template Engine Freemarker Support (Java 11)
>>> 1.1.100.202001140305 (org.eclipse.tools.templates.freemarker.java11
>>> 1.1.100.202001140305)
>>> Contains: Template Engine Freemarker Support (Java 11)
>>> 1.1.2.201911192140 (org.eclipse.tools.templates.freemarker.java11
>>> 1.1.2.201911192140)
>>> Contains: Cannot satisfy dependency:
>>> Contains: From: C/C++ Arduino Tools 9.11.0.202001140305
>>> (org.eclipse.cdt.arduino.feature.group 9.11.0.202001140305)
>>> Contains: To: org.eclipse.equinox.p2.iu;
>>> org.eclipse.tools.templates.freemarker.java11
>>> [1.1.100.202001140305,1.1.100.202001140305]
>>>
>>> Is it problem related to my environment? I'm still using 2019-12.
>>> _______________________________________________
>>> cdt-dev mailing list
>>> [hidden email]
>>> To unsubscribe from this list, visit
>>> https://www.eclipse.org/mailman/listinfo/cdt-dev
>>>
>>
>> _______________________________________________
>> cdt-dev mailing list
>> [hidden email]
>> To unsubscribe from this list, visit
>> https://www.eclipse.org/mailman/listinfo/cdt-dev
> _______________________________________________
> cdt-dev mailing list
> [hidden email]
> To unsubscribe from this list, visit
> https://www.eclipse.org/mailman/listinfo/cdt-dev

_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev

_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev