BREE 11?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

BREE 11?

Ed Merks-2
Hi,

I understand the platform's products for 4.17 will require Java 11 and
that this was already changed via:

   https://bugs.eclipse.org/bugs/show_bug.cgi?id=564035

I've had to adapt the Product Catalog Generator to properly take into
account the fact that while the 4.17 IBuild of the platform's products
require Java 11, there are as yet no EPP packages that require Java 11. 
I expect that will be the case for all the EPP packages for 2020-09 M1,
but it's a bit of odd transitional state...

What's not clear to me though is whether the BREEs of any platform's own
bundles will change to Java 11.  Currently it's still possible to build
the Eclipse Installer against the 4.17 IBuild such that it still runs on
Java 1.8, but if the BREEs of the platform's own bundles change, that
won't be the case.

What should my expectations be looking forward?  Sorry if this was
already clarified previously and I didn't pay close enough attention...

Regards,
Ed




_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev
Reply | Threaded
Open this post in threaded view
|

Re: BREE 11?

Rolf Theunissen
Hi

As a side note, I have seen strange behavior on the IBuilds w.r.t. injection running on Java 8 (after the javax.annotation update), see https://eclip.se/564264. Also I did not pay close attention, so don't know what is supposed to work and what not.

Regards,
Rolf

Op vr 26 jun. 2020 om 11:30 schreef Ed Merks <[hidden email]>:
Hi,

I understand the platform's products for 4.17 will require Java 11 and
that this was already changed via:

   https://bugs.eclipse.org/bugs/show_bug.cgi?id=564035

I've had to adapt the Product Catalog Generator to properly take into
account the fact that while the 4.17 IBuild of the platform's products
require Java 11, there are as yet no EPP packages that require Java 11. 
I expect that will be the case for all the EPP packages for 2020-09 M1,
but it's a bit of odd transitional state...

What's not clear to me though is whether the BREEs of any platform's own
bundles will change to Java 11.  Currently it's still possible to build
the Eclipse Installer against the 4.17 IBuild such that it still runs on
Java 1.8, but if the BREEs of the platform's own bundles change, that
won't be the case.

What should my expectations be looking forward?  Sorry if this was
already clarified previously and I didn't pay close enough attention...

Regards,
Ed




_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev

_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev
Reply | Threaded
Open this post in threaded view
|

Re: BREE 11?

Lars Vogel-2
Hi Ed,

I think it is safer to assume that some bundles will increase their
BREE to Java 11. If the platform in general requires it, I think it is
fine to use Java 11 also in individual bundles.

Best regards, Lars

On Fri, Jun 26, 2020 at 11:46 AM Rolf Theunissen
<[hidden email]> wrote:

>
> Hi
>
> As a side note, I have seen strange behavior on the IBuilds w.r.t. injection running on Java 8 (after the javax.annotation update), see https://eclip.se/564264. Also I did not pay close attention, so don't know what is supposed to work and what not.
>
> Regards,
> Rolf
>
> Op vr 26 jun. 2020 om 11:30 schreef Ed Merks <[hidden email]>:
>>
>> Hi,
>>
>> I understand the platform's products for 4.17 will require Java 11 and
>> that this was already changed via:
>>
>>    https://bugs.eclipse.org/bugs/show_bug.cgi?id=564035
>>
>> I've had to adapt the Product Catalog Generator to properly take into
>> account the fact that while the 4.17 IBuild of the platform's products
>> require Java 11, there are as yet no EPP packages that require Java 11.
>> I expect that will be the case for all the EPP packages for 2020-09 M1,
>> but it's a bit of odd transitional state...
>>
>> What's not clear to me though is whether the BREEs of any platform's own
>> bundles will change to Java 11.  Currently it's still possible to build
>> the Eclipse Installer against the 4.17 IBuild such that it still runs on
>> Java 1.8, but if the BREEs of the platform's own bundles change, that
>> won't be the case.
>>
>> What should my expectations be looking forward?  Sorry if this was
>> already clarified previously and I didn't pay close enough attention...
>>
>> Regards,
>> Ed
>>
>>
>>
>>
>> _______________________________________________
>> platform-dev mailing list
>> [hidden email]
>> To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev
>
> _______________________________________________
> platform-dev mailing list
> [hidden email]
> To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev



--
Eclipse Platform project co-lead
CEO vogella GmbH

Haindaalwisch 17a, 22395 Hamburg
Amtsgericht Hamburg: HRB 127058
Geschäftsführer: Lars Vogel, Jennifer Nerlich de Vogel
USt-IdNr.: DE284122352
Fax (040) 5247 6322, Email: [hidden email], Web: http://www.vogella.com
_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev
Reply | Threaded
Open this post in threaded view
|

Re: BREE 11?

Aleksandar Kurtakov
In reply to this post by Rolf Theunissen


On Fri, Jun 26, 2020 at 12:46 PM Rolf Theunissen <[hidden email]> wrote:
Hi

As a side note, I have seen strange behavior on the IBuilds w.r.t. injection running on Java 8 (after the javax.annotation update), see https://eclip.se/564264. Also I did not pay close attention, so don't know what is supposed to work and what not.


Rolf, it is unclear to me what the issue is after javax.annotation update. Would you please explain in more detail? Either here on in bugzilla and add me on cc.


Regards,
Rolf

Op vr 26 jun. 2020 om 11:30 schreef Ed Merks <[hidden email]>:
Hi,

I understand the platform's products for 4.17 will require Java 11 and
that this was already changed via:

   https://bugs.eclipse.org/bugs/show_bug.cgi?id=564035

I've had to adapt the Product Catalog Generator to properly take into
account the fact that while the 4.17 IBuild of the platform's products
require Java 11, there are as yet no EPP packages that require Java 11. 
I expect that will be the case for all the EPP packages for 2020-09 M1,
but it's a bit of odd transitional state...

What's not clear to me though is whether the BREEs of any platform's own
bundles will change to Java 11.  Currently it's still possible to build
the Eclipse Installer against the 4.17 IBuild such that it still runs on
Java 1.8, but if the BREEs of the platform's own bundles change, that
won't be the case.

What should my expectations be looking forward?  Sorry if this was
already clarified previously and I didn't pay close enough attention...

Regards,
Ed




_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev
_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev


--
Alexander Kurtakov
Red Hat Eclipse Team

_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev
Reply | Threaded
Open this post in threaded view
|

Re: BREE 11?

Rolf Theunissen
Aleksander,

I included the incorrect Bug number, it should be https://eclip.se/564515. Running on Java 8 all the 'spies' did not open correctly, i.e. @PostConstruct is not called, with Java 11 it works fine. 

Op ma 29 jun. 2020 om 08:34 schreef Aleksandar Kurtakov <[hidden email]>:


On Fri, Jun 26, 2020 at 12:46 PM Rolf Theunissen <[hidden email]> wrote:
Hi

As a side note, I have seen strange behavior on the IBuilds w.r.t. injection running on Java 8 (after the javax.annotation update), see https://eclip.se/564264. Also I did not pay close attention, so don't know what is supposed to work and what not.


Rolf, it is unclear to me what the issue is after javax.annotation update. Would you please explain in more detail? Either here on in bugzilla and add me on cc.


Regards,
Rolf

Op vr 26 jun. 2020 om 11:30 schreef Ed Merks <[hidden email]>:
Hi,

I understand the platform's products for 4.17 will require Java 11 and
that this was already changed via:

   https://bugs.eclipse.org/bugs/show_bug.cgi?id=564035

I've had to adapt the Product Catalog Generator to properly take into
account the fact that while the 4.17 IBuild of the platform's products
require Java 11, there are as yet no EPP packages that require Java 11. 
I expect that will be the case for all the EPP packages for 2020-09 M1,
but it's a bit of odd transitional state...

What's not clear to me though is whether the BREEs of any platform's own
bundles will change to Java 11.  Currently it's still possible to build
the Eclipse Installer against the 4.17 IBuild such that it still runs on
Java 1.8, but if the BREEs of the platform's own bundles change, that
won't be the case.

What should my expectations be looking forward?  Sorry if this was
already clarified previously and I didn't pay close enough attention...

Regards,
Ed




_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev
_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev


--
Alexander Kurtakov
Red Hat Eclipse Team
_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev

_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev
Reply | Threaded
Open this post in threaded view
|

Re: BREE 11?

Daniel Megert
In reply to this post by Lars Vogel-2
There will be for sure bundles that have the JavaSE-11BREE. One example is Jetty 10 which was the initial driver to move to Java 11.

Dani



From:        Lars Vogel <[hidden email]>
To:        "Eclipse platform general developers list." <[hidden email]>
Date:        26.06.2020 16:50
Subject:        [EXTERNAL] Re: [platform-dev] BREE 11?
Sent by:        [hidden email]




Hi Ed,

I think it is safer to assume that some bundles will increase their
BREE to Java 11. If the platform in general requires it, I think it is
fine to use Java 11 also in individual bundles.

Best regards, Lars

On Fri, Jun 26, 2020 at 11:46 AM Rolf Theunissen
<[hidden email]> wrote:

>
> Hi
>
> As a side note, I have seen strange behavior on the IBuilds w.r.t. injection running on Java 8 (after the javax.annotation update), see
https://eclip.se/564264. Also I did not pay close attention, so don't know what is supposed to work and what not.
>
> Regards,
> Rolf
>
> Op vr 26 jun. 2020 om 11:30 schreef Ed Merks <[hidden email]>:
>>
>> Hi,
>>
>> I understand the platform's products for 4.17 will require Java 11 and
>> that this was already changed via:
>>
>>    
https://bugs.eclipse.org/bugs/show_bug.cgi?id=564035
>>
>> I've had to adapt the Product Catalog Generator to properly take into
>> account the fact that while the 4.17 IBuild of the platform's products
>> require Java 11, there are as yet no EPP packages that require Java 11.
>> I expect that will be the case for all the EPP packages for 2020-09 M1,
>> but it's a bit of odd transitional state...
>>
>> What's not clear to me though is whether the BREEs of any platform's own
>> bundles will change to Java 11.  Currently it's still possible to build
>> the Eclipse Installer against the 4.17 IBuild such that it still runs on
>> Java 1.8, but if the BREEs of the platform's own bundles change, that
>> won't be the case.
>>
>> What should my expectations be looking forward?  Sorry if this was
>> already clarified previously and I didn't pay close enough attention...
>>
>> Regards,
>> Ed
>>
>>
>>
>>
>> _______________________________________________
>> platform-dev mailing list
>> [hidden email]
>> To unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/platform-dev
>
> _______________________________________________
> platform-dev mailing list
> [hidden email]
> To unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/platform-dev



--
Eclipse Platform project co-lead
CEO vogella GmbH

Haindaalwisch 17a, 22395 Hamburg
Amtsgericht Hamburg: HRB 127058
Geschäftsführer: Lars Vogel, Jennifer Nerlich de Vogel
USt-IdNr.: DE284122352
Fax (040) 5247 6322, Email: [hidden email], Web:
http://www.vogella.com
_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/platform-dev





_______________________________________________
platform-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/platform-dev