Debugging HTTP Transfer

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Debugging HTTP Transfer

Gunnar Wagenknecht
Greetings,

I'm debugging a weird Tycho issue with p2 and target platform resolution. Unfortunately, the Maven debug logs aren't helpful. Is there a way to trigger logging of HTTP communication in ECF?

The exception I'm seeing in the build is a FileNotFoundException.
Caused by: java.io.FileNotFoundException: http://download.eclipse.org/releases/2018-09/201809191002/content.xml.xz

However, the URL works fine on my local machine and from the build machine. But the Tycho build consistently fails on the build machine (not on my local).

--
Gunnar Wagenknecht
[hidden email], http://guw.io/






_______________________________________________
ecf-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/ecf-dev
Reply | Threaded
Open this post in threaded view
|

Re: Debugging HTTP Transfer

Scott Lewis-2
On 10/25/2018 10:35 AM, Gunnar Wagenknecht wrote:
> Greetings,
>
> I'm debugging a weird Tycho issue with p2 and target platform resolution. Unfortunately, the Maven debug logs aren't helpful. Is there a way to trigger logging of HTTP communication in ECF?

ECF currently uses version 4.5.5 (orbit) of httpclient.   The logging
config is described here:

http://hc.apache.org/httpcomponents-client-ga/logging.html

>
> The exception I'm seeing in the build is a FileNotFoundException.
> Caused by: java.io.FileNotFoundException: http://download.eclipse.org/releases/2018-09/201809191002/content.xml.xz

hmm...strange.    If it seems that this is an ECF issue, please add me
to the created bug.

Scott

_______________________________________________
ecf-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/ecf-dev
Reply | Threaded
Open this post in threaded view
|

Re: Debugging HTTP Transfer

Scott Lewis-2
Also...in case it's helpful:   We use these props for configuring
logging when running our filetransfer test cases in this project:

http://git.eclipse.org/c/ecf/org.eclipse.ecf.git/tree/tests/bundles/org.eclipse.ecf.tests.filetransfer

We have some tests of gzip file retrieve (and unpack) in
URLRetrieveTest.   If you like, you could change the URL that's used to
retrieve to your file...if it helps.

Scott

On 10/25/2018 12:35 PM, Scott Lewis wrote:

> On 10/25/2018 10:35 AM, Gunnar Wagenknecht wrote:
>> Greetings,
>>
>> I'm debugging a weird Tycho issue with p2 and target platform
>> resolution. Unfortunately, the Maven debug logs aren't helpful. Is
>> there a way to trigger logging of HTTP communication in ECF?
>
> ECF currently uses version 4.5.5 (orbit) of httpclient.   The logging
> config is described here:
>
> http://hc.apache.org/httpcomponents-client-ga/logging.html
>
>>
>> The exception I'm seeing in the build is a FileNotFoundException.
>> Caused by: java.io.FileNotFoundException:
>> http://download.eclipse.org/releases/2018-09/201809191002/content.xml.xz
>
> hmm...strange.    If it seems that this is an ECF issue, please add me
> to the created bug.
>
> Scott
>
> _______________________________________________
> ecf-dev mailing list
> [hidden email]
> To change your delivery options, retrieve your password, or
> unsubscribe from this list, visit
> https://www.eclipse.org/mailman/listinfo/ecf-dev


_______________________________________________
ecf-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/ecf-dev