Declaring Build for wtp-R3.9.0-I: S-3.9.0M6-20170314000054

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Declaring Build for wtp-R3.9.0-I: S-3.9.0M6-20170314000054

Carl Anderson
 

Download Page:
http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M6-20170314000054

General Smoketest results page:
http://wiki.eclipse.org/WTP_Smoke_Test_Results

_______________________________________________
wtp-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Declaring Build for wtp-R3.9.0-I: S-3.9.0M6-20170314000054

konstantin.komissarchik

There is a Jetty dependency issue in WTP M6 build.

 

     [java] Cannot complete the install because one or more required items could not be found.

     [java]  Software being installed: WST Server Adapters 3.2.500.v201703012025 (org.eclipse.wst.server_adapters.featur

e.feature.group 3.2.500.v201703012025)

    [java]  Missing requirement: Jetty :: Webapp Application Support 9.4.0.v20161208 (org.eclipse.jetty.webapp 9.4.0.v2

0161208) requires 'package org.eclipse.jetty.http [9.4.0,9.4.1)' but it could not be found

     [java]  Cannot satisfy dependency:

     [java]   From: Preview Server Support 1.1.400.v201703012025 (org.eclipse.wst.server.preview 1.1.400.v201703012025)

     [java]   To: bundle org.eclipse.jetty.webapp [8.0.4,10.0.0)

     [java]  Cannot satisfy dependency:

     [java]   From: WST Server Adapters 3.2.500.v201703012025 (org.eclipse.wst.server_adapters.feature.feature.group 3.2

.500.v201703012025)

     [java]   To: org.eclipse.wst.server.preview [1.1.400.v201703012025]

     [java] Application failed, log file location: D:\Oracle\OEPE\Depot\trunk\oxygen\build\p2\configuration\148960517627

 

WTP M6 requires [9.4.0,9.4.1) while Platform M6 packs 9.4.1.

 

Why is that dependency range so narrow? Is it possible to do a respin of M6?

 

Thanks,

 

- Konstantin

 

 

From: [hidden email]
Sent: Wednesday, March 15, 2017 5:55 AM
To: [hidden email]
Subject: [wtp-dev] Declaring Build for wtp-R3.9.0-I: S-3.9.0M6-20170314000054

 

 

Download Page:

http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M6-20170314000054

 

General Smoketest results page:

http://wiki.eclipse.org/WTP_Smoke_Test_Results

 

_______________________________________________

wtp-dev mailing list

[hidden email]

To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/wtp-dev

 


_______________________________________________
wtp-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Declaring Build for wtp-R3.9.0-I:S-3.9.0M6-20170314000054

konstantin.komissarchik
In reply to this post by Carl Anderson

The issue is real, but never mind on the analysis. The real problem, of course, is that Platform includes Jetty 9.4.1, while WTP includes Jetty 9.4.0, so pieces of Jetty don’t match up.

 

- Konstantin

 

From: [hidden email]
Sent: Wednesday, March 15, 2017 12:17 PM
To: [hidden email]; [hidden email]
Subject: RE: [wtp-dev] Declaring Build for wtp-R3.9.0-I:S-3.9.0M6-20170314000054

 

There is a Jetty dependency issue in WTP M6 build.

 

     [java] Cannot complete the install because one or more required items could not be found.

     [java]  Software being installed: WST Server Adapters 3.2.500.v201703012025 (org.eclipse.wst.server_adapters.featur

e.feature.group 3.2.500.v201703012025)

    [java]  Missing requirement: Jetty :: Webapp Application Support 9.4.0.v20161208 (org.eclipse.jetty.webapp 9.4.0.v2

0161208) requires 'package org.eclipse.jetty.http [9.4.0,9.4.1)' but it could not be found

     [java]  Cannot satisfy dependency:

     [java]   From: Preview Server Support 1.1.400.v201703012025 (org.eclipse.wst.server.preview 1.1.400.v201703012025)

     [java]   To: bundle org.eclipse.jetty.webapp [8.0.4,10.0.0)

     [java]  Cannot satisfy dependency:

     [java]   From: WST Server Adapters 3.2.500.v201703012025 (org.eclipse.wst.server_adapters.feature.feature.group 3.2

.500.v201703012025)

     [java]   To: org.eclipse.wst.server.preview [1.1.400.v201703012025]

     [java] Application failed, log file location: D:\Oracle\OEPE\Depot\trunk\oxygen\build\p2\configuration\148960517627

 

WTP M6 requires [9.4.0,9.4.1) while Platform M6 packs 9.4.1.

 

Why is that dependency range so narrow? Is it possible to do a respin of M6?

 

Thanks,

 

- Konstantin

 

 

From: [hidden email]
Sent: Wednesday, March 15, 2017 5:55 AM
To: [hidden email]
Subject: [wtp-dev] Declaring Build for wtp-R3.9.0-I: S-3.9.0M6-20170314000054

 

 

Download Page:

http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M6-20170314000054

 

General Smoketest results page:

http://wiki.eclipse.org/WTP_Smoke_Test_Results

 

_______________________________________________

wtp-dev mailing list

[hidden email]

To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/wtp-dev

 

 


_______________________________________________
wtp-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Declaring Build for wtp-R3.9.0-I:S-3.9.0M6-20170314000054

Carl Anderson

Konstantin,

Can you verify that this issue is fixed with http://build.eclipse.org/webtools/committers/wtp-R3.9.0-I/20170316133614/I-3.9.0-20170316133614/? It may be too late to get a respin of the M6 EPPs, but we can ask once you verify that this is fixed.

FWIW,

- Carl Anderson
WTP Releng Project lead

Inactive hide details for ---03/15/2017 03:51:03 PM---The issue is real, but never mind on the analysis. The real problem, of c---03/15/2017 03:51:03 PM---The issue is real, but never mind on the analysis. The real problem, of course, is that Platform inc

From: <[hidden email]>
To: Carl Anderson/Raleigh/IBM@IBMUS, "[hidden email]" <[hidden email]>
Date: 03/15/2017 03:51 PM
Subject: RE: [wtp-dev] Declaring Build for wtp-R3.9.0-I:S-3.9.0M6-20170314000054





The issue is real, but never mind on the analysis. The real problem, of course, is that Platform includes Jetty 9.4.1, while WTP includes Jetty 9.4.0, so pieces of Jetty don’t match up.

- Konstantin

From: [hidden email]
Sent:
Wednesday, March 15, 2017 12:17 PM
To:
[hidden email]; [hidden email]
Subject:
RE: [wtp-dev] Declaring Build for wtp-R3.9.0-I:S-3.9.0M6-20170314000054

There is a Jetty dependency issue in WTP M6 build.

[java] Cannot complete the install because one or more required items could not be found.
[java] Software being installed: WST Server Adapters 3.2.500.v201703012025 (org.eclipse.wst.server_adapters.featur
e.feature.group 3.2.500.v201703012025)
[java] Missing requirement: Jetty :: Webapp Application Support 9.4.0.v20161208 (org.eclipse.jetty.webapp 9.4.0.v2
0161208) requires 'package org.eclipse.jetty.http [9.4.0,9.4.1)' but it could not be found
[java] Cannot satisfy dependency:
[java] From: Preview Server Support 1.1.400.v201703012025 (org.eclipse.wst.server.preview 1.1.400.v201703012025)
[java] To: bundle org.eclipse.jetty.webapp [8.0.4,10.0.0)
[java] Cannot satisfy dependency:
[java] From: WST Server Adapters 3.2.500.v201703012025 (org.eclipse.wst.server_adapters.feature.feature.group 3.2
.500.v201703012025)
[java] To: org.eclipse.wst.server.preview [1.1.400.v201703012025]
[java] Application failed, log file location: D:\Oracle\OEPE\Depot\trunk\oxygen\build\p2\configuration\148960517627

WTP M6 requires [9.4.0,9.4.1) while Platform M6 packs 9.4.1.

Why is that dependency range so narrow? Is it possible to do a respin of M6?

Thanks,

- Konstantin


From: [hidden email]
Sent:
Wednesday, March 15, 2017 5:55 AM
To:
[hidden email]
Subject:
[wtp-dev] Declaring Build for wtp-R3.9.0-I: S-3.9.0M6-20170314000054


Download Page:
http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M6-20170314000054

General Smoketest results page:
http://wiki.eclipse.org/WTP_Smoke_Test_Results

_______________________________________________
wtp-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-dev




_______________________________________________
wtp-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Declaring Build forwtp-R3.9.0-I:S-3.9.0M6-20170314000054

konstantin.komissarchik

Carl,

 

I have verified that this build resolves the issue present in WTP 3.9 M6 build. I suspect that it’s to late to respin M6 at this point.

 

The workaround when installing WTP 3.9 M6 over top platform (not using simrel repo) is to explicitly add Jetty 9.4 repository to the list of available repositories. I am fairly certain that the problem is not present in the simrel repo (haven’t verified) or else aggregation would fail. I am guessing that another party is supplying Jetty 9.4 to the mix so WTP dependencies are resolved. Folks installing WTP from the simrel repo should not be affected by this issue.

 

Caveat: I am assuming that multiple versions of Jetty can peacefully coexist in the same install without runtime issues.

 

Thanks,

 

- Konstantin

 

 

From: [hidden email]
Sent: Thursday, March 16, 2017 1:23 PM
To: [hidden email]
Subject: Re: [wtp-dev] Declaring Build forwtp-R3.9.0-I:S-3.9.0M6-20170314000054

 

Konstantin,

Can you verify that this issue is fixed with http://build.eclipse.org/webtools/committers/wtp-R3.9.0-I/20170316133614/I-3.9.0-20170316133614/? It may be too late to get a respin of the M6 EPPs, but we can ask once you verify that this is fixed.

FWIW,

- Carl Anderson
WTP Releng Project lead

Inactive hide details for ---03/15/2017 03:51:03 PM---The issue is real, but never mind on the analysis. The real problem, of c---03/15/2017 03:51:03 PM---The issue is real, but never mind on the analysis. The real problem, of course, is that Platform inc

From: <[hidden email]>
To: Carl Anderson/Raleigh/IBM@IBMUS, "[hidden email]" <[hidden email]>
Date: 03/15/2017 03:51 PM
Subject: RE: [wtp-dev] Declaring Build for wtp-R3.9.0-I:S-3.9.0M6-20170314000054




The issue is real, but never mind on the analysis. The real problem, of course, is that Platform includes Jetty 9.4.1, while WTP includes Jetty 9.4.0, so pieces of Jetty don’t match up.

- Konstantin

From: [hidden email]
Sent:
Wednesday, March 15, 2017 12:17 PM
To:
[hidden email]; [hidden email]
Subject:
RE: [wtp-dev] Declaring Build for wtp-R3.9.0-I:S-3.9.0M6-20170314000054

There is a Jetty dependency issue in WTP M6 build.

[java] Cannot complete the install because one or more required items could not be found.
[java] Software being installed: WST Server Adapters 3.2.500.v201703012025 (org.eclipse.wst.server_adapters.featur
e.feature.group 3.2.500.v201703012025)
[java] Missing requirement: Jetty :: Webapp Application Support 9.4.0.v20161208 (org.eclipse.jetty.webapp 9.4.0.v2
0161208) requires 'package org.eclipse.jetty.http [9.4.0,9.4.1)' but it could not be found
[java] Cannot satisfy dependency:
[java] From: Preview Server Support 1.1.400.v201703012025 (org.eclipse.wst.server.preview 1.1.400.v201703012025)
[java] To: bundle org.eclipse.jetty.webapp [8.0.4,10.0.0)
[java] Cannot satisfy dependency:
[java] From: WST Server Adapters 3.2.500.v201703012025 (org.eclipse.wst.server_adapters.feature.feature.group 3.2
.500.v201703012025)
[java] To: org.eclipse.wst.server.preview [1.1.400.v201703012025]
[java] Application failed, log file location: D:\Oracle\OEPE\Depot\trunk\oxygen\build\p2\configuration\148960517627

WTP M6 requires [9.4.0,9.4.1) while Platform M6 packs 9.4.1.

Why is that dependency range so narrow? Is it possible to do a respin of M6?

Thanks,

- Konstantin


From: [hidden email]
Sent:
Wednesday, March 15, 2017 5:55 AM
To:
[hidden email]
Subject:
[wtp-dev] Declaring Build for wtp-R3.9.0-I: S-3.9.0M6-20170314000054


Download Page:
http://download.eclipse.org/webtools/downloads/drops/R3.9.0/S-3.9.0M6-20170314000054

General Smoketest results page:
http://wiki.eclipse.org/WTP_Smoke_Test_Results

_______________________________________________
wtp-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-dev


 


_______________________________________________
wtp-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-dev
Loading...