Maven version issue

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Maven version issue

Ming Cheng

Hi,

 

Now I run Eclipse committers on Linux trying to avoid any possible windows env bug since I don’t know how to install dockers and jenkinfilers. Still my humble objective is to build CDT jars. I imported CDT source code 9.10.0 and right-click Maven build

 

 

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:46 min

[INFO] Finished at: 2020-01-16T12:45:26+08:00

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M3:enforce (enforce-maven-version) on project org.eclipse.cdt.core.native: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

[ERROR] Detected Maven Version: 3.6.1 is not in the allowed range [3.6.0,3.6.0].

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

My current Eclipse version is:

Eclipse IDE for Eclipse Committers

 

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

 

 

I also downloaded older build like 2019-03/2018-12 etc. But the bundled maven version are 3.5.3. (So which Eclipse uses 3.6.0 maven?)

 

It seems impossible to change Maven usage setting within Eclipse:

 

 

I tried and couldn’t save.

 

Thanks.

 

Sent from Mail for Windows 10

 


_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Maven version issue

Jonah Graham
On Linux try in a terminal:

cd path-to-cdt
mvn package 

Jonah

On Wed., Jan. 15, 2020, 23:52 Ming Cheng, <[hidden email]> wrote:

Hi,

 

Now I run Eclipse committers on Linux trying to avoid any possible windows env bug since I don’t know how to install dockers and jenkinfilers. Still my humble objective is to build CDT jars. I imported CDT source code 9.10.0 and right-click Maven build

 

 

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:46 min

[INFO] Finished at: 2020-01-16T12:45:26+08:00

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M3:enforce (enforce-maven-version) on project org.eclipse.cdt.core.native: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

[ERROR] Detected Maven Version: 3.6.1 is not in the allowed range [3.6.0,3.6.0].

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

My current Eclipse version is:

Eclipse IDE for Eclipse Committers

 

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

 

 

I also downloaded older build like 2019-03/2018-12 etc. But the bundled maven version are 3.5.3. (So which Eclipse uses 3.6.0 maven?)

 

It seems impossible to change Maven usage setting within Eclipse:

 

 

I tried and couldn’t save.

 

Thanks.

 

Sent from Mail for Windows 10

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

C699D193BD0B447B8B6F77B39039710A.png (56K) Download Attachment
4A3D80B4C3A846C29CC9364D7CC577D6.png (260K) Download Attachment
C699D193BD0B447B8B6F77B39039710A.png (56K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Maven version issue

Jonah Graham
Hi,

I have finished the modernisation of some of the release engineering documentation I started in December - you can find the command line build instructions in the repo at https://git.eclipse.org/c/cdt/org.eclipse.cdt.git/tree/README.md

Jonah


~~~
Jonah Graham
Kichwa Coders
www.kichwacoders.com


On Thu, 16 Jan 2020 at 07:21, Jonah Graham <[hidden email]> wrote:
On Linux try in a terminal:

cd path-to-cdt
mvn package 

Jonah

On Wed., Jan. 15, 2020, 23:52 Ming Cheng, <[hidden email]> wrote:

Hi,

 

Now I run Eclipse committers on Linux trying to avoid any possible windows env bug since I don’t know how to install dockers and jenkinfilers. Still my humble objective is to build CDT jars. I imported CDT source code 9.10.0 and right-click Maven build

 

 

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:46 min

[INFO] Finished at: 2020-01-16T12:45:26+08:00

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M3:enforce (enforce-maven-version) on project org.eclipse.cdt.core.native: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

[ERROR] Detected Maven Version: 3.6.1 is not in the allowed range [3.6.0,3.6.0].

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

My current Eclipse version is:

Eclipse IDE for Eclipse Committers

 

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

 

 

I also downloaded older build like 2019-03/2018-12 etc. But the bundled maven version are 3.5.3. (So which Eclipse uses 3.6.0 maven?)

 

It seems impossible to change Maven usage setting within Eclipse:

 

 

I tried and couldn’t save.

 

Thanks.

 

Sent from Mail for Windows 10

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Maven version issue

Ming Cheng
In reply to this post by Jonah Graham

Hi Jonah and All,

 

Thanks for the advice that I can now build ALL CDT jars after a couple of months!

 

Now I tried to add a couple of JOptionPane.showMessageDialog stmt in file NewClassCodeGenerator.java and I could compile successfully also.

 

I want my Eclipse to use this new org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar in my Eclipse CDT version:

 

Eclipse IDE for C/C++ Developers

 

Version: 2018-09 (4.9.0)

Build id: 20180917-1800

 

How to do it?

 

If I simply replace org.eclipse.cdt.ui_6.3.1.201809121146.jar with org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar, Eclipse will give me an error:

 

 

In my com.umlet.plugin code, I called NewClassCodeGenerator.

 

Thanks.

 

Sent from Mail for Windows 10

 

From: [hidden email]
Sent: Thursday, January 16, 2020 8:21 PM
To: [hidden email]
Subject: Re: [cdt-dev] Maven version issue

 

On Linux try in a terminal:

 

cd path-to-cdt

mvn package 

 

Jonah

 

On Wed., Jan. 15, 2020, 23:52 Ming Cheng, <[hidden email]> wrote:

Hi,

 

Now I run Eclipse committers on Linux trying to avoid any possible windows env bug since I don’t know how to install dockers and jenkinfilers. Still my humble objective is to build CDT jars. I imported CDT source code 9.10.0 and right-click Maven build

 

 

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:46 min

[INFO] Finished at: 2020-01-16T12:45:26+08:00

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M3:enforce (enforce-maven-version) on project org.eclipse.cdt.core.native: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

[ERROR] Detected Maven Version: 3.6.1 is not in the allowed range [3.6.0,3.6.0].

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

My current Eclipse version is:

Eclipse IDE for Eclipse Committers

 

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

 

 

I also downloaded older build like 2019-03/2018-12 etc. But the bundled maven version are 3.5.3. (So which Eclipse uses 3.6.0 maven?)

 

It seems impossible to change Maven usage setting within Eclipse:

 

 

I tried and couldn’t save.

 

Thanks.

 

Sent from Mail for Windows 10

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

 


_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Maven version issue

Ming Cheng

Keen to have your guide to move. Thanks.

 

Sent from Mail for Windows 10

 


From: [hidden email] <[hidden email]> on behalf of Ming Cheng <[hidden email]>
Sent: Monday, January 20, 2020 12:12:13 PM
To: CDT General developers list. <[hidden email]>
Subject: Re: [cdt-dev] Maven version issue
 

Hi Jonah and All,

 

Thanks for the advice that I can now build ALL CDT jars after a couple of months!

 

Now I tried to add a couple of JOptionPane.showMessageDialog stmt in file NewClassCodeGenerator.java and I could compile successfully also.

 

I want my Eclipse to use this new org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar in my Eclipse CDT version:

 

Eclipse IDE for C/C++ Developers

 

Version: 2018-09 (4.9.0)

Build id: 20180917-1800

 

How to do it?

 

If I simply replace org.eclipse.cdt.ui_6.3.1.201809121146.jar with org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar, Eclipse will give me an error:

 

 

In my com.umlet.plugin code, I called NewClassCodeGenerator.

 

Thanks.

 

Sent from Mail for Windows 10

 

From: [hidden email]
Sent: Thursday, January 16, 2020 8:21 PM
To: [hidden email]
Subject: Re: [cdt-dev] Maven version issue

 

On Linux try in a terminal:

 

cd path-to-cdt

mvn package 

 

Jonah

 

On Wed., Jan. 15, 2020, 23:52 Ming Cheng, <[hidden email]> wrote:

Hi,

 

Now I run Eclipse committers on Linux trying to avoid any possible windows env bug since I don’t know how to install dockers and jenkinfilers. Still my humble objective is to build CDT jars. I imported CDT source code 9.10.0 and right-click Maven build

 

 

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:46 min

[INFO] Finished at: 2020-01-16T12:45:26+08:00

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M3:enforce (enforce-maven-version) on project org.eclipse.cdt.core.native: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

[ERROR] Detected Maven Version: 3.6.1 is not in the allowed range [3.6.0,3.6.0].

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

My current Eclipse version is:

Eclipse IDE for Eclipse Committers

 

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

 

 

I also downloaded older build like 2019-03/2018-12 etc. But the bundled maven version are 3.5.3. (So which Eclipse uses 3.6.0 maven?)

 

It seems impossible to change Maven usage setting within Eclipse:

 

 

I tried and couldn’t save.

 

Thanks.

 

Sent from Mail for Windows 10

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

 


_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Maven version issue

Jonah Graham
Hello,

I recently responded to a similar question, please see https://www.eclipse.org/lists/cdt-dev/msg33979.html

However, this mailing list is really for development of CDT and most of your questions are basic Java and Eclipse development questions. For example, you persist it trying to mixing AWT/Swing code with SWT. You haven't shown what you have done to try and resolve your problems, nor provided stack traces or even transcribed many of the error messages encountered. 

I really want to support your endeavours, and I have signposted you to solutions and options in private emails that I have had no response to. 

Please continue to submit CDT specific queries, with relevant stack traces, reproducible code and/or what steps you have taken to resolve the problem.

Thank you, 
Jonah 


On Tue., Jan. 21, 2020, 19:45 Ming Cheng, <[hidden email]> wrote:

Keen to have your guide to move. Thanks.

 

Sent from Mail for Windows 10

 


From: [hidden email] <[hidden email]> on behalf of Ming Cheng <[hidden email]>
Sent: Monday, January 20, 2020 12:12:13 PM
To: CDT General developers list. <[hidden email]>
Subject: Re: [cdt-dev] Maven version issue
 

Hi Jonah and All,

 

Thanks for the advice that I can now build ALL CDT jars after a couple of months!

 

Now I tried to add a couple of JOptionPane.showMessageDialog stmt in file NewClassCodeGenerator.java and I could compile successfully also.

 

I want my Eclipse to use this new org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar in my Eclipse CDT version:

 

Eclipse IDE for C/C++ Developers

 

Version: 2018-09 (4.9.0)

Build id: 20180917-1800

 

How to do it?

 

If I simply replace org.eclipse.cdt.ui_6.3.1.201809121146.jar with org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar, Eclipse will give me an error:

 

 

In my com.umlet.plugin code, I called NewClassCodeGenerator.

 

Thanks.

 

Sent from Mail for Windows 10

 

From: [hidden email]
Sent: Thursday, January 16, 2020 8:21 PM
To: [hidden email]
Subject: Re: [cdt-dev] Maven version issue

 

On Linux try in a terminal:

 

cd path-to-cdt

mvn package 

 

Jonah

 

On Wed., Jan. 15, 2020, 23:52 Ming Cheng, <[hidden email]> wrote:

Hi,

 

Now I run Eclipse committers on Linux trying to avoid any possible windows env bug since I don’t know how to install dockers and jenkinfilers. Still my humble objective is to build CDT jars. I imported CDT source code 9.10.0 and right-click Maven build

 

cid:image002.png@01D5CC6B.C28041D0

 

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:46 min

[INFO] Finished at: 2020-01-16T12:45:26+08:00

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M3:enforce (enforce-maven-version) on project org.eclipse.cdt.core.native: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

[ERROR] Detected Maven Version: 3.6.1 is not in the allowed range [3.6.0,3.6.0].

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

My current Eclipse version is:

Eclipse IDE for Eclipse Committers

 

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

 

 

I also downloaded older build like 2019-03/2018-12 etc. But the bundled maven version are 3.5.3. (So which Eclipse uses 3.6.0 maven?)

 

It seems impossible to change Maven usage setting within Eclipse:

 

cid:image004.png@01D5CC6B.C1DE5C80

 

I tried and couldn’t save.

 

Thanks.

 

Sent from Mail for Windows 10

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

1760CE1D61BA451E9E90087DC2294D18.png (12K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Maven version issue

Ming Cheng

Hi Graham,

 

I’ll spend time to study  https://www.eclipse.org/lists/cdt-dev/msg33979.html.

Please see my comments inline below and hope you and other Eclipse/CDT experts can have better pic of my purpose.

 

Warm Regards.

 

Sent from Mail for Windows 10

 

From: [hidden email]
Sent: Wednesday, January 22, 2020 9:09 AM
To: [hidden email]
Subject: Re: [cdt-dev] Maven version issue

 

Hello,

 

I recently responded to a similar question, please see https://www.eclipse.org/lists/cdt-dev/msg33979.html

 

However, this mailing list is really for development of CDT and most of your questions are basic Java and Eclipse development questions.

[MC]  Yes my purpose is indeed very basic. So my questions are also very basic.  So far I don’t have skill/knowledge to contribute to Eclipse/CDT development. I just want to make use of CDT C++ coding capability. UMLet gives me UML modeling feature and if I can modify it with come CDT function calls to generate C++ code, then it achieves my purpose.

For example, you persist it trying to mixing AWT/Swing code with SWT.

[MC]  I don’t know AWT/Swing/SWT in detail. I heard of them. I am a C++ developer and based on my C++ experience to try to change UMLet java code. UMLet Eclipse plugin seems supporting Eclipse quite well. Now there are 2 possibilities that UMLet plugin code may have AWT, or may no. If there is AWT, then if I just add some CDT function calls without introducing more AWT code, hope the changed plugin should be ok (?) bcos I believe CDT does not have AWT code. If UMLet plugin does NOT have any AWT, then everyone is happy. So I don’t persist to mixing AWT code with SWT.  Swing code yes bcos I guess UMLet uses Swing. Would it be an issue?

 

You haven't shown what you have done to try and resolve your problems, nor provided stack traces or even transcribed many of the error messages encountered. 

[MC]  This is really the core issue I am facing so far. I tried to add some CDT calls into UMLet Eclipse plugin code but either no effect or hang there. I don’t know how to trace UMLet Eclipse plugin within Eclipse CDT version. What I can think of is to add some printing stmt directly within CDT functions I will use in order to share with your CDT experts. Now I can compile CDT jars but encountered some issue lists in the thread which you can find further below. I’d like to follow any better steps in detail if I don’t need to change CDT but can still trace UMLet Eclipse plugin call stacks. In short changing CDT code is not my purpose.

 

I really want to support your endeavours, and I have signposted you to solutions and options in private emails that I have had no response to. 

[MC]   thanks again and this is why I can continue to try. Otherwise I could have stopped much earlier.

Please continue to submit CDT specific queries, with relevant stack traces, reproducible code and/or what steps you have taken to resolve the problem.

 

Thank you, 

Jonah 

 

On Tue., Jan. 21, 2020, 19:45 Ming Cheng, <[hidden email]> wrote:

Keen to have your guide to move. Thanks.

 

Sent from Mail for Windows 10

 

From: [hidden email] <[hidden email]> on behalf of Ming Cheng <[hidden email]>
Sent: Monday, January 20, 2020 12:12:13 PM
To: CDT General developers list. <[hidden email]>
Subject: Re: [cdt-dev] Maven version issue

 

Hi Jonah and All,

 

Thanks for the advice that I can now build ALL CDT jars after a couple of months!

 

Now I tried to add a couple of JOptionPane.showMessageDialog stmt in file NewClassCodeGenerator.java and I could compile successfully also.

 

I want my Eclipse to use this new org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar in my Eclipse CDT version:

 

Eclipse IDE for C/C++ Developers

 

Version: 2018-09 (4.9.0)

Build id: 20180917-1800

 

How to do it?

 

If I simply replace org.eclipse.cdt.ui_6.3.1.201809121146.jar with org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar, Eclipse will give me an error:

 

 

In my com.umlet.plugin code, I called NewClassCodeGenerator.

 

Thanks.

 

Sent from Mail for Windows 10

 

From: [hidden email]
Sent: Thursday, January 16, 2020 8:21 PM
To: [hidden email]
Subject: Re: [cdt-dev] Maven version issue

 

On Linux try in a terminal:

 

cd path-to-cdt

mvn package 

 

Jonah

 

On Wed., Jan. 15, 2020, 23:52 Ming Cheng, <[hidden email]> wrote:

Hi,

 

Now I run Eclipse committers on Linux trying to avoid any possible windows env bug since I don’t know how to install dockers and jenkinfilers. Still my humble objective is to build CDT jars. I imported CDT source code 9.10.0 and right-click Maven build

 

 

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:46 min

[INFO] Finished at: 2020-01-16T12:45:26+08:00

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M3:enforce (enforce-maven-version) on project org.eclipse.cdt.core.native: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

[ERROR] Detected Maven Version: 3.6.1 is not in the allowed range [3.6.0,3.6.0].

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

My current Eclipse version is:

Eclipse IDE for Eclipse Committers

 

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

 

 

I also downloaded older build like 2019-03/2018-12 etc. But the bundled maven version are 3.5.3. (So which Eclipse uses 3.6.0 maven?)

 

It seems impossible to change Maven usage setting within Eclipse:

 

 

I tried and couldn’t save.

 

Thanks.

 

Sent from Mail for Windows 10

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

 


_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Maven version issue

Ming Cheng

Hi Jonah,

 

I tried Export method(ExportProjectProvider is beyond my understanding and skill).

 

 

When click Finish, I got this error:

 

 

I remembered this was why I was told to run “mvn package” on my Linux platform.

 

Since my mvn way was ok and I have all (or most jar files). Could I try “Then you can install that P2 repo into an Eclipse installation. You should be able to install it into just the Eclipse Platform Binary (as labelled on https://download.eclipse.org/eclipse/downloads/drops4/R-4.14-201912100610/)) similarily?

 

 

But it did not work.

 

I can change CDT code locally, but couldn’t use them in an installed Eclipse/CDT build.

 

Thanks.

 

Sent from Mail for Windows 10

 

From: [hidden email]
Sent: Thursday, January 23, 2020 3:21 PM
To: [hidden email]
Subject: Re: [cdt-dev] Maven version issue

 

Hi Graham,

 

I’ll spend time to study  https://www.eclipse.org/lists/cdt-dev/msg33979.html.

Please see my comments inline below and hope you and other Eclipse/CDT experts can have better pic of my purpose.

 

Warm Regards.

 

Sent from Mail for Windows 10

 

From: [hidden email]
Sent: Wednesday, January 22, 2020 9:09 AM
To: [hidden email]
Subject: Re: [cdt-dev] Maven version issue

 

Hello,

 

I recently responded to a similar question, please see https://www.eclipse.org/lists/cdt-dev/msg33979.html

 

However, this mailing list is really for development of CDT and most of your questions are basic Java and Eclipse development questions.

[MC]  Yes my purpose is indeed very basic. So my questions are also very basic.  So far I don’t have skill/knowledge to contribute to Eclipse/CDT development. I just want to make use of CDT C++ coding capability. UMLet gives me UML modeling feature and if I can modify it with come CDT function calls to generate C++ code, then it achieves my purpose.

For example, you persist it trying to mixing AWT/Swing code with SWT.

[MC]  I don’t know AWT/Swing/SWT in detail. I heard of them. I am a C++ developer and based on my C++ experience to try to change UMLet java code. UMLet Eclipse plugin seems supporting Eclipse quite well. Now there are 2 possibilities that UMLet plugin code may have AWT, or may no. If there is AWT, then if I just add some CDT function calls without introducing more AWT code, hope the changed plugin should be ok (?) bcos I believe CDT does not have AWT code. If UMLet plugin does NOT have any AWT, then everyone is happy. So I don’t persist to mixing AWT code with SWT.  Swing code yes bcos I guess UMLet uses Swing. Would it be an issue?

 

You haven't shown what you have done to try and resolve your problems, nor provided stack traces or even transcribed many of the error messages encountered. 

[MC]  This is really the core issue I am facing so far. I tried to add some CDT calls into UMLet Eclipse plugin code but either no effect or hang there. I don’t know how to trace UMLet Eclipse plugin within Eclipse CDT version. What I can think of is to add some printing stmt directly within CDT functions I will use in order to share with your CDT experts. Now I can compile CDT jars but encountered some issue lists in the thread which you can find further below. I’d like to follow any better steps in detail if I don’t need to change CDT but can still trace UMLet Eclipse plugin call stacks. In short changing CDT code is not my purpose.

 

I really want to support your endeavours, and I have signposted you to solutions and options in private emails that I have had no response to. 

[MC]   thanks again and this is why I can continue to try. Otherwise I could have stopped much earlier.

Please continue to submit CDT specific queries, with relevant stack traces, reproducible code and/or what steps you have taken to resolve the problem.

 

Thank you, 

Jonah 

 

On Tue., Jan. 21, 2020, 19:45 Ming Cheng, <[hidden email]> wrote:

Keen to have your guide to move. Thanks.

 

Sent from Mail for Windows 10

 

cid:image002.png@01D5D200.AE6A1B40

From: [hidden email] <[hidden email]> on behalf of Ming Cheng <[hidden email]>
Sent: Monday, January 20, 2020 12:12:13 PM
To: CDT General developers list. <[hidden email]>
Subject: Re: [cdt-dev] Maven version issue

 

Hi Jonah and All,

 

Thanks for the advice that I can now build ALL CDT jars after a couple of months!

 

Now I tried to add a couple of JOptionPane.showMessageDialog stmt in file NewClassCodeGenerator.java and I could compile successfully also.

 

I want my Eclipse to use this new org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar in my Eclipse CDT version:

 

Eclipse IDE for C/C++ Developers

 

Version: 2018-09 (4.9.0)

Build id: 20180917-1800

 

How to do it?

 

If I simply replace org.eclipse.cdt.ui_6.3.1.201809121146.jar with org.eclipse.cdt.ui-6.6.100-SNAPSHOT.jar, Eclipse will give me an error:

 

 

In my com.umlet.plugin code, I called NewClassCodeGenerator.

 

Thanks.

 

Sent from Mail for Windows 10

 

From: [hidden email]
Sent: Thursday, January 16, 2020 8:21 PM
To: [hidden email]
Subject: Re: [cdt-dev] Maven version issue

 

On Linux try in a terminal:

 

cd path-to-cdt

mvn package 

 

Jonah

 

On Wed., Jan. 15, 2020, 23:52 Ming Cheng, <[hidden email]> wrote:

Hi,

 

Now I run Eclipse committers on Linux trying to avoid any possible windows env bug since I don’t know how to install dockers and jenkinfilers. Still my humble objective is to build CDT jars. I imported CDT source code 9.10.0 and right-click Maven build

 

 

[INFO] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time:  02:46 min

[INFO] Finished at: 2020-01-16T12:45:26+08:00

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M3:enforce (enforce-maven-version) on project org.eclipse.cdt.core.native: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:

[ERROR] Detected Maven Version: 3.6.1 is not in the allowed range [3.6.0,3.6.0].

[ERROR] -> [Help 1]

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

 

My current Eclipse version is:

Eclipse IDE for Eclipse Committers

 

Version: 2019-06 (4.12.0)

Build id: 20190614-1200

 

 

I also downloaded older build like 2019-03/2018-12 etc. But the bundled maven version are 3.5.3. (So which Eclipse uses 3.6.0 maven?)

 

It seems impossible to change Maven usage setting within Eclipse:

 

 

I tried and couldn’t save.

 

Thanks.

 

Sent from Mail for Windows 10

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

 

_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev

 

 


_______________________________________________
cdt-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://www.eclipse.org/mailman/listinfo/cdt-dev