Multiple projects problems

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Multiple projects problems

Pavol Zibrita
Hi!

  I'm new to the list and this plugin as well. And It's quite impressive
for me. But, I have a problem with it. Our project consist of 3
projects, where they are depended in hierarchy. There is some 'root'
project, than 'product project' which depends on the root project, then
'customer project' which depeneds on the product project.

  We have tests in separate source dir in each project, but that's not a
problem.

When I have tried to turn on the CT in the root project, it was not
working. Simply, the test rerun was not triggered (even the first run
after seting up the CT was not executed). What I tried, was closing the
'product & customer projects' so that only the root project was opened.
Than the CT was working!!

Strange for me. It seems the multiple projects are handled some other
way. Actually I'm not good at 'eclipse plugin' making, because I would
look at the plugin myself....

Any idea what I'm doing wrong, or it is a bug or feature? :).

Regards,
P. Zibrita

_______________________________________________
Continuous-testing-plugin-discuss mailing list
[hidden email]
https://lists.csail.mit.edu/mailman/listinfo/continuous-testing-plugin-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Multiple projects problems

dsaff
Pavol,

Were there any compile errors in your other two projects?  There is a
bug in CT 1.2.x that causes any compile error, anywhere, to prevent
tests running in any project.  This is being fixed in CT 2.0 (about
which expect an announcement in the next 24 hours).

    David Saff

Pavol Zibrita wrote:

> Hi!
>
>   I'm new to the list and this plugin as well. And It's quite impressive
> for me. But, I have a problem with it. Our project consist of 3
> projects, where they are depended in hierarchy. There is some 'root'
> project, than 'product project' which depends on the root project, then
> 'customer project' which depeneds on the product project.
>
>   We have tests in separate source dir in each project, but that's not a
> problem.
>
> When I have tried to turn on the CT in the root project, it was not
> working. Simply, the test rerun was not triggered (even the first run
> after seting up the CT was not executed). What I tried, was closing the
> 'product & customer projects' so that only the root project was opened.
> Than the CT was working!!
>
> Strange for me. It seems the multiple projects are handled some other
> way. Actually I'm not good at 'eclipse plugin' making, because I would
> look at the plugin myself....
>
> Any idea what I'm doing wrong, or it is a bug or feature? :).
>
> Regards,
> P. Zibrita
>
> _______________________________________________
> Continuous-testing-plugin-discuss mailing list
> [hidden email]
> https://lists.csail.mit.edu/mailman/listinfo/continuous-testing-plugin-discuss
>  


_______________________________________________
Continuous-testing-plugin-discuss mailing list
[hidden email]
https://lists.csail.mit.edu/mailman/listinfo/continuous-testing-plugin-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Multiple projects problems

Pavol Zibrita
Hi again!

David Saff wrote:
> Pavol,
>
> Were there any // FIXME or other high-priority tasks in any of the
> projects?  This has been reported as being a problem, although we
> haven't been able to replicate it yet.  Thanks,
>

Yes, we have planty of such tasks.

Pavol

PS: I forgot to write, that I'm running the eclipse on java 1.5 because
of the Mylar plugin. If this helps..

>    David Saff
>
> Pavol Zibrita wrote:
>
>> David,
>>
>>    No, there were no compile errors.
>>
>> I tried the tutorial and it worked perfectly. But in tutorial there were
>> 2 projects with same CT setting. I have 3 projects and I want each
>> project to have its own tests run. We generate a testsuite class with
>> all tests ('AllTests') wich I set to be run as the test suite in CT
>> settings.
>>
>> Pavol
>>
>> PS: Maybe, if the problem will persist also in CT 2.0, I will try to
>> setup the environment for the plugin and debug it...
>>
>> David Saff wrote:
>>  
>>
>>> Pavol,
>>>
>>> Were there any compile errors in your other two projects?  There is a
>>> bug in CT 1.2.x that causes any compile error, anywhere, to prevent
>>> tests running in any project.  This is being fixed in CT 2.0 (about
>>> which expect an announcement in the next 24 hours).
>>>
>>>    David Saff
>>>
>>> Pavol Zibrita wrote:
>>>
>>>    
>>>
>>>> Hi!
>>>>
>>>>   I'm new to the list and this plugin as well. And It's quite
>>>> impressive
>>>> for me. But, I have a problem with it. Our project consist of 3
>>>> projects, where they are depended in hierarchy. There is some 'root'
>>>> project, than 'product project' which depends on the root project, then
>>>> 'customer project' which depeneds on the product project.
>>>>
>>>>   We have tests in separate source dir in each project, but that's
>>>> not a
>>>> problem.
>>>>
>>>> When I have tried to turn on the CT in the root project, it was not
>>>> working. Simply, the test rerun was not triggered (even the first run
>>>> after seting up the CT was not executed). What I tried, was closing the
>>>> 'product & customer projects' so that only the root project was opened.
>>>> Than the CT was working!!
>>>>
>>>> Strange for me. It seems the multiple projects are handled some other
>>>> way. Actually I'm not good at 'eclipse plugin' making, because I would
>>>> look at the plugin myself....
>>>>
>>>> Any idea what I'm doing wrong, or it is a bug or feature? :).
>>>>
>>>> Regards,
>>>> P. Zibrita
>>>>
>>>> _______________________________________________
>>>> Continuous-testing-plugin-discuss mailing list
>>>> [hidden email]
>>>> https://lists.csail.mit.edu/mailman/listinfo/continuous-testing-plugin-discuss
>>>>
>>>>
>>>>        
>>>
>>>
>>>    
>
>
>

_______________________________________________
Continuous-testing-plugin-discuss mailing list
[hidden email]
https://lists.csail.mit.edu/mailman/listinfo/continuous-testing-plugin-discuss