P2 Tests

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

P2 Tests

David Weiser
Hi everyone,

I am currently working on this enhancement https://git.eclipse.org/r/#/c/89530/ in p2.

The tests are failing and I am trying to get them to run locally. With no success.

What I did so far:
I added the Eclipse testing framework. I imported org.eclipse.core.tests.harness from the eclipse.runtime bundle. To solve the error "No available bundle exports package 'org.eclipse.equinox.http' I imported the rt.equinox.bundle without success (erros still there). 

When I run "All p2 tests" I get one error (testCancellation) and 56 failures (assertInitialized). When I try to run "All p2 UI Tests" it is not started at all. It seems that org.eclipse.osgi can't find bundles?!

What am I missing? Any idea what is wrong? 

If you need additional information, just contact me.

Thanks in advance!

Regards
David




_______________________________________________
equinox-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev
Reply | Threaded
Open this post in threaded view
|

Re: P2 Tests

Roland Grunberg
On Wed, 2017-03-01 at 09:52 +0100, David Weiser wrote:
> What I did so far:
> I added the Eclipse testing framework. I imported
> org.eclipse.core.tests.harness from the eclipse.runtime bundle. To
> solve the error "No available bundle exports package
> 'org.eclipse.equinox.http' I imported the rt.equinox.bundle without
> success (erros still there). 

I remember when I ran the p2 tests, I also couldn't resolve
'org.eclipse.equinox.http' but I wasn't really dealing with that part
of the code. The last repository I could find it in was :

http://download.eclipse.org/releases/indigo/

IU: org.eclipse.equinox.http 1.0.500.v20110413
* java.package/org.eclipse.equinox.http/0.0.0

If you're not dealing with p2.testserver though, you should be able to
just close the project and only run the tests you care about.

> When I run "All p2 tests" I get one error (testCancellation) and 56
> failures (assertInitialized). When I try to run "All p2 UI Tests" it
> is not started at all. It seems that org.eclipse.osgi can't find
> bundles?!
>
> What am I missing? Any idea what is wrong? 

I always ran the tests with my default target platform, but more
recently, it hasn't worked out so I took p2-mars.target and made some
changes to get it working with neon and oxygen targets. Not sure why
those weren't updated (everything run through maven anyways?). I filed
https://bugs.eclipse.org/bugs/show_bug.cgi?id=512323 .


Hope this helps,
--
Roland Grunberg
_______________________________________________
equinox-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev