PDE plugins to have minimum execution environment JavaSE-1.8 - in scope of 4.7 M5?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

PDE plugins to have minimum execution environment JavaSE-1.8 - in scope of 4.7 M5?

Martin Karpisek-2
Hi,
i would like to ask if it will be possible to check patches for setting all remaining PDE plugins to Java 1.8 (bug [1]) sometime at the begining of 4.7 M5? 
(and actualy rasing versons would be ok, or not to be done now)

Reason is, that I think i will be able to provide more patches (also in timeframe of M5) and having all plugins(ee/compiler) of PDE on same version (java8) would somehow help in it (also helps in general i think).
(for example o.e.pde.ua is still java 1.4, some other are on java 1.5, rest is allready on 1.8).

On comment from Lars bugfix is devided now to 2 patches (for all non-apitools [2] and apitools plugins [3]), so probably could be applied/reviewed step by step

Thank you
Martin.



_______________________________________________
pde-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/pde-dev
Reply | Threaded
Open this post in threaded view
|

Re: PDE plugins to have minimum execution environment JavaSE-1.8 - in scope of 4.7 M5?

Lars Vogel-2
Hi Martin,

I plan to review and integrate https://git.eclipse.org/r/#/c/85528/ soon.

Best regards, Lars

On Sat, Dec 10, 2016 at 1:42 PM, Martin Karpisek
<[hidden email]> wrote:

> Hi,
> i would like to ask if it will be possible to check patches for setting all
> remaining PDE plugins to Java 1.8 (bug [1]) sometime at the begining of 4.7
> M5?
> (and actualy rasing versons would be ok, or not to be done now)
>
> Reason is, that I think i will be able to provide more patches (also in
> timeframe of M5) and having all plugins(ee/compiler) of PDE on same version
> (java8) would somehow help in it (also helps in general i think).
> (for example o.e.pde.ua is still java 1.4, some other are on java 1.5, rest
> is allready on 1.8).
>
> On comment from Lars bugfix is devided now to 2 patches (for all
> non-apitools [2] and apitools plugins [3]), so probably could be
> applied/reviewed step by step
>
> Thank you
> Martin.
>
> [1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=507971
> [2] https://git.eclipse.org/r/#/c/85528/
> [3] https://git.eclipse.org/r/#/c/85899/
>



--
Eclipse Platform UI and e4 project co-lead
CEO vogella GmbH

Haindaalwisch 17a, 22395 Hamburg
Amtsgericht Hamburg: HRB 127058
Geschäftsführer: Lars Vogel, Jennifer Nerlich de Vogel
USt-IdNr.: DE284122352
Fax (040) 5247 6322, Email: [hidden email], Web: http://www.vogella.com
_______________________________________________
pde-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/pde-dev