Plugin-updates are impossible if Eclipse runs with Java 8

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Plugin-updates are impossible if Eclipse runs with Java 8

15 knots
This is what blocks users:

Cannot complete the install because some dependencies are not satisfiable
  Software being installed: a.jre.javase 14.0.0
  Software currently installed: C/C++ Autotools support
9.11.1.202004012023 (org.eclipse.cdt.autotools.feature.group
9.11.1.202004012023)
  Cannot satisfy dependency:
    From: C/C++ Autotools support 9.11.1.202004012023
(org.eclipse.cdt.autotools.feature.group 9.11.1.202004012023)
    To: org.eclipse.equinox.p2.iu;
org.eclipse.tools.templates.freemarker.java11
[1.1.100.202001140305,1.1.100.202001140305]
  Cannot satisfy dependency:
    From: Template Engine Freemarker Support (Java 11)
1.1.100.202001140305 (org.eclipse.tools.templates.freemarker.java11
1.1.100.202001140305)
    To: osgi.ee; (&(osgi.ee=JavaSE)(version=11))

org.eclipse.tools.templates.freemarker.java11 is a fragment bundle
hosted on org.eclipse.tools.templates.freemarker

Why does the autotools feature require
org.eclipse.tools.templates.freemarker.java11 but not its host bundle?

Martin
_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Plugin-updates are impossible if Eclipse runs with Java 8

Mark B
It's a dependency bug, you just need to disable the Java compatibility check in the preferences under "install" menu.

Il Sab 8 Ago 2020, 13:34 15 knots <[hidden email]> ha scritto:
This is what blocks users:

Cannot complete the install because some dependencies are not satisfiable
  Software being installed: a.jre.javase 14.0.0
  Software currently installed: C/C++ Autotools support
9.11.1.202004012023 (org.eclipse.cdt.autotools.feature.group
9.11.1.202004012023)
  Cannot satisfy dependency:
    From: C/C++ Autotools support 9.11.1.202004012023
(org.eclipse.cdt.autotools.feature.group 9.11.1.202004012023)
    To: org.eclipse.equinox.p2.iu;
org.eclipse.tools.templates.freemarker.java11
[1.1.100.202001140305,1.1.100.202001140305]
  Cannot satisfy dependency:
    From: Template Engine Freemarker Support (Java 11)
1.1.100.202001140305 (org.eclipse.tools.templates.freemarker.java11
1.1.100.202001140305)
    To: osgi.ee; (&(osgi.ee=JavaSE)(version=11))

org.eclipse.tools.templates.freemarker.java11 is a fragment bundle
hosted on org.eclipse.tools.templates.freemarker

Why does the autotools feature require
org.eclipse.tools.templates.freemarker.java11 but not its host bundle?

Martin
_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev

_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Plugin-updates are impossible if Eclipse runs with Java 8

15 knots
Am Sa., 8. Aug. 2020 um 13:36 Uhr schrieb Mark B <[hidden email]>:
>
> It's a dependency bug, you just need to disable the Java compatibility check in the preferences under "install" menu.

Is there already a bug report tracking this or should I raise one?
_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev
Reply | Threaded
Open this post in threaded view
|

Re: Plugin-updates are impossible if Eclipse runs with Java 8

Mark B
I remember there was a bug report opened by Jonah.

Il sab 8 ago 2020, 13:51 15 knots <[hidden email]> ha scritto:
Am Sa., 8. Aug. 2020 um 13:36 Uhr schrieb Mark B <[hidden email]>:
>
> It's a dependency bug, you just need to disable the Java compatibility check in the preferences under "install" menu.

Is there already a bug report tracking this or should I raise one?
_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev

_______________________________________________
cdt-dev mailing list
[hidden email]
To unsubscribe from this list, visit https://www.eclipse.org/mailman/listinfo/cdt-dev