Re: Help Request: Feature and Plug-in Versions

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Help Request: Feature and Plug-in Versions

akurtakov (Bugzilla)


On Thu, May 11, 2017 at 11:00 AM, Daniel Megert <[hidden email]> wrote:
Your help is requested. We have a several features (bug 516456) and many plug-ins (bug 516457) that need a version increase.

In order to avoid several people fixing the same bundles, I suggest to add a bugzilla comment BEFORE you start fixing.

Those changes do not require a review, unless you are not 100% sure how the new version must look like. In that case, please ask in the bug report.

Dani, should we push such changes today? Or wait for M7 to be declared before doing so?

 


Thanks for your help!
Dani

_______________________________________________
eclipse-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev


_______________________________________________
eclipse-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev
Reply | Threaded
Open this post in threaded view
|

Re: Help Request: Feature and Plug-in Versions

Daniel Megert
Hi Alex

The bugs are targeted for RC1. You should wait until M7 is done. There might be a rebuild request from SWT.

Dani



From:        akurtakov <[hidden email]>
To:        "General development mailing list of the Eclipse project." <[hidden email]>
Date:        11.05.2017 13:31
Subject:        Re: [eclipse-dev] Help Request: Feature and Plug-in Versions
Sent by:        [hidden email]






On Thu, May 11, 2017 at 11:00 AM, Daniel Megert <daniel_megert@...> wrote:
Your help is requested. We have a several features (bug 516456) and many plug-ins (bug 516457) that need a version increase.

In order to avoid several people fixing the same bundles, I suggest to add a bugzilla comment BEFORE you start fixing.


Those changes do not require a review, unless you are not 100% sure how the new version must look like. In that case, please ask in the bug report.


Dani, should we push such changes today? Or wait for M7 to be declared before doing so?

 


Thanks for your help!
Dani


_______________________________________________
eclipse-dev mailing list

[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/eclipse-dev
_______________________________________________
eclipse-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev



_______________________________________________
eclipse-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev
Reply | Threaded
Open this post in threaded view
|

Re: Help Request: Feature and Plug-in Versions

Sravan K Lakkimsetti
In reply to this post by akurtakov (Bugzilla)

We have downgraded tycho to 0.26.0 yesterday due to Bug 516424. These version changes require us to use version 1.1.0 to compare versions with poms and manifest files. I would prefer to do that in RC1. So lets wait for M7 to be declared

 

-Sravan

 

From: akurtakov [mailto:[hidden email]]
Sent: Thursday, May 11, 2017 5:02 PM
To: General development mailing list of the Eclipse project. <[hidden email]>
Subject: Re: [eclipse-dev] Help Request: Feature and Plug-in Versions

 

 

 

On Thu, May 11, 2017 at 11:00 AM, Daniel Megert <[hidden email]> wrote:

Your help is requested. We have a several features (bug 516456) and many plug-ins (bug 516457) that need a version increase.

In order to avoid several people fixing the same bundles, I suggest to add a bugzilla comment BEFORE you start fixing.

Those changes do not require a review, unless you are not 100% sure how the new version must look like. In that case, please ask in the bug report.

 

Dani, should we push such changes today? Or wait for M7 to be declared before doing so?

 



Thanks for your help!
Dani

_______________________________________________
eclipse-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev

 



_______________________________________________
eclipse-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev
Reply | Threaded
Open this post in threaded view
|

Re: Help Request: Feature and Plug-in Versions

Sravan K Lakkimsetti
In reply to this post by akurtakov (Bugzilla)

Since Tycho has released a new version 1.1.0 today I will be moving to it once M7 is declared.
Version updates can be made as soon as M7 is declared. RC1 builds will happen with latest Tycho version.

Thanks and Regards,
Sravan

Sravan Kumar Lakkimsetti
IBM India Pvt Ltd,
Embassy Golf Links Business Park, D Block,
Off Indiranagar-Kormangla Inner Ring Road,
Bangalore - 560071, India
Phone: 91-80-41776858


Inactive hide details for "Sravan K Lakkimsetti" ---11-05-2017 05:33:48 PM---We have downgraded tycho to 0.26.0 yesterday due t"Sravan K Lakkimsetti" ---11-05-2017 05:33:48 PM---We have downgraded tycho to 0.26.0 yesterday due to Bug <https://bugs.eclipse.org/bugs/show_bug.cgi?

From: "Sravan K Lakkimsetti" <[hidden email]>
To: "General development mailing list of the Eclipse project." <[hidden email]>
Date: 11-05-17 05:33 PM
Subject: Re: [eclipse-dev] Help Request: Feature and Plug-in Versions
Sent by: [hidden email]





We have downgraded tycho to 0.26.0 yesterday due to Bug 516424. These version changes require us to use version 1.1.0 to compare versions with poms and manifest files. I would prefer to do that in RC1. So lets wait for M7 to be declared

-Sravan

From: akurtakov [[hidden email]]
Sent:
Thursday, May 11, 2017 5:02 PM
To:
General development mailing list of the Eclipse project. <[hidden email]>
Subject:
Re: [eclipse-dev] Help Request: Feature and Plug-in Versions



On Thu, May 11, 2017 at 11:00 AM, Daniel Megert <[hidden email]> wrote:
Your help is requested. We have a several features (bug 516456) and many plug-ins (bug 516457) that need a version increase.

In order to avoid several people fixing the same bundles, I suggest to add a bugzilla comment BEFORE you start fixing.


Those changes do not require a review, unless you are not 100% sure how the new version must look like. In that case, please ask in the bug report.


Dani, should we push such changes today? Or wait for M7 to be declared before doing so?



Thanks for your help!
Dani


_______________________________________________
eclipse-dev mailing list

[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/eclipse-dev

_______________________________________________
eclipse-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev



_______________________________________________
eclipse-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev