Smoke Test Request for WTP 3.10.0 I-build

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

Smoke Test Request for WTP 3.10.0 I-build

Carl Anderson

Smoke Test Request for WTP 3.10.0 I-build

Please document your Project's testing and approval of this build,
by 5 PM EDT Monday, or let us know if that's not possible.

Current Build
http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/

Smoketest Results
https://wiki.eclipse.org/WTP_Smoke_Test_Results_R3100_01252018

FWIW,

- Carl Anderson
WTP Build guy

_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng

Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build - M5

Carl Anderson

Folks,

I missed adding this in the initial smoke test request- this is for Photon M5.

FWIW,

- Carl Anderson
WTP Build guy

Inactive hide details for "Carl Anderson" ---01/25/2018 09:35:36 AM---Smoke Test Request for WTP 3.10.0 I-build Please document"Carl Anderson" ---01/25/2018 09:35:36 AM---Smoke Test Request for WTP 3.10.0 I-build Please document your Project's testing and approval of thi

From: "Carl Anderson" <[hidden email]>
To: "Webtools releng discussion list" <[hidden email]>
Date: 01/25/2018 09:35 AM
Subject: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
Sent by: [hidden email]





Smoke Test Request for WTP 3.10.0 I-build

Please document your Project's testing and approval of this build,
by 5 PM EDT Monday, or let us know if that's not possible.


Current Build

http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/

Smoketest Results

https://wiki.eclipse.org/WTP_Smoke_Test_Results_R3100_01252018

FWIW,


- Carl Anderson
WTP Build guy
_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6JCYBixIS0G6Rj43h5xZSA&m=SoULd0jpzWtoRQPD3JbhhrRae5y-SCwadR0SxT19fME&s=i1PL-2RgHBl2QuB5cHjt4_FVH0ZReWrMCQkwrsoOdTM&e=


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Nick Boldt-3
In reply to this post by Carl Anderson
Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

 == webtools.javaee == 
* 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
* ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
* 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

 == webtools.jsdt == 
* d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

 == webtools.jsf == 
* 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

 == webtools.sourceediting == 
* a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
* b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
* 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

Should these be included in M5? If so, we need a respin.

On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:

Smoke Test Request for WTP 3.10.0 I-build

Please document your Project's testing and approval of this build,
by 5 PM EDT Monday, or let us know if that's not possible.

Current Build
http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/

Smoketest Results
https://wiki.eclipse.org/WTP_Smoke_Test_Results_R3100_01252018

FWIW,

- Carl Anderson
WTP Build guy


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng



--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Victor V. Rubezhny-3
In reply to this post by Carl Anderson
Hello!

Can't even start Photon+WTP (See the exception below).
Probably the reason is that I've used eclipse-SDK-I20180124-2000 instead of proposed eclipse-SDK-I20171218-2000...
But there's no te december's one at http://download.eclipse.org/eclipse/downloads/index.html

Where can I find it?

Tanks in advance,
Victor


Here's the last exception from my log:

!ENTRY org.eclipse.osgi 4 0 2018-01-26 19:32:31.299
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.ui.ide.workbench" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.touchpoint.natives.nativePackageExtractor, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool, org.eclipse.jdt.apt.core.aptBuild, org.eclipse.jdt.core.JavaCodeFormatter, org.eclipse.jdt.core.JavaIndexer, org.eclipse.pde.build.Build, org.eclipse.pde.junit.runtime.uitestapplication, org.eclipse.pde.junit.runtime.legacytestapplication, org.eclipse.pde.junit.runtime.coretestapplication, org.eclipse.pde.junit.runtime.coretestapplicationnonmain, org.eclipse.pde.junit.runtime.nonuithreadtestapplication, org.eclipse.emf.codegen.CodeGen, org.eclipse.emf.codegen.JMerger, org.eclipse.emf.codegen.ecore.Generator, org.eclipse.emf.importer.ecore.Ecore2GenModel, org.eclipse.emf.importer.java.Java2GenModel, org.eclipse.emf.importer.rose.Rose2GenModel, org.eclipse.xsd.ecore.importer.XSD2GenModel, org.eclipse.datatools.connectivity.console.profile.StorageFileEditor, org.eclipse.emf.mwe.core.WorkflowRunner, org.eclipse.wst.jsdt.core.JavaCodeFormatter.
    at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
    at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:656)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:592)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1498)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1471)



On 01/25/2018 03:29 PM, Carl Anderson wrote:

Smoke Test Request for WTP 3.10.0 I-build

Please document your Project's testing and approval of this build,
by 5 PM EDT Monday, or let us know if that's not possible.

Current Build
http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/

Smoketest Results
https://wiki.eclipse.org/WTP_Smoke_Test_Results_R3100_01252018

FWIW,

- Carl Anderson
WTP Build guy


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng



_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Carl Anderson
In reply to this post by Nick Boldt-3

Nick,

We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to bNick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

From: Nick Boldt <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Date: 01/25/2018 04:52 PM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
Sent by: [hidden email]





Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

 == webtools.javaee == 
* 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
* ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
* 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

 == webtools.jsdt == 
* d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

 == webtools.jsf == 
* 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

 == webtools.sourceediting == 
* a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
* b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
* 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

Should these be included in M5? If so, we need a respin.

On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:


--
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio
IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.
@ @redhatnews      Red Hat_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6JCYBixIS0G6Rj43h5xZSA&m=b9sSeUbR6wV7_MNYAkyOGh8bsW4cQsCoWvnK3jmAIVs&s=-Satni66-iIvm3Vyw0y7j-VYbYYK1_3QqlWu1uZxSFM&e=


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Nick Boldt-3
I pulled in the latest commits from these 4 repos:

* 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.



On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:

Nick,

We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to bNick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

From: Nick Boldt <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Date: 01/25/2018 04:52 PM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
Sent by: [hidden email]





Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

 == webtools.javaee == 
* 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
* ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
* 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

 == webtools.jsdt == 
* d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

 == webtools.jsf == 
* 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

 == webtools.sourceediting == 
* a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
* b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
* 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

Should these be included in M5? If so, we need a respin.

On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:


--
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio
IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.
@ @redhatnews      Red Hat_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6JCYBixIS0G6Rj43h5xZSA&m=b9sSeUbR6wV7_MNYAkyOGh8bsW4cQsCoWvnK3jmAIVs&s=-Satni66-iIvm3Vyw0y7j-VYbYYK1_3QqlWu1uZxSFM&e=




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Nick Boldt-3
And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

[DEBUG] Closing connection to remote
[ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure: 
[ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46] 
[ERROR] 	lastTransformerInChain.getSerializationHandler().flushPending();
[ERROR] 	                       ^^^^^^^^^^^^^^^^^^^^^^^
[ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
[ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131] 
[ERROR] 	currentLine = e.m_styleNode.getEndLineNumber();
[ERROR] 	                            ^^^^^^^^^^^^^^^^
[ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
[ERROR] 2 problems (2 errors)

Back to you in the studio, sourceediting folks.

https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
I pulled in the latest commits from these 4 repos:

* 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.



On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:

Nick,

We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to bNick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

From: Nick Boldt <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Date: 01/25/2018 04:52 PM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
Sent by: [hidden email]





Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

 == webtools.javaee == 
* 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
* ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
* 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

 == webtools.jsdt == 
* d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

 == webtools.jsf == 
* 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

 == webtools.sourceediting == 
* a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
* b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
* 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

Should these be included in M5? If so, we need a respin.

On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:


--
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio
IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.
@ @redhatnews      Red Hat_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6JCYBixIS0G6Rj43h5xZSA&m=b9sSeUbR6wV7_MNYAkyOGh8bsW4cQsCoWvnK3jmAIVs&s=-Satni66-iIvm3Vyw0y7j-VYbYYK1_3QqlWu1uZxSFM&e=




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Carl Anderson

Folks,

This was all caused by Nick's fix to bug 527813 , which moved WTP from including the two Jetty plugins that the Platform does not ship, to simply requiring those plugins. BIRT includes the 9.4.5 version of those plugins (yet, the platform, and WTP, moved up to Jetty 9.4.7 for Oxygen.2 and Photon M4). If you look at comment #31 on that bug, you will find the link to the repo that you need to add in order to resolve this dependency during WTP's install.

Nick,

Due to issues that have arisen with adopters using Oxygen.2 and everyone using Photon M5, should we revisit the decision to move this from an include to a require? Right now, WTP is at the mercy of other teams like BIRT, which includes the 9.4.5 versions of these Jetty plugins in Photon. The Eclipse Platform does not include all of the Jetty plugins that WTP requires, and there is no direct contribution of the Jetty plugins to the simultaneous release aggregation. From a release engineering standpoint, this is not ideal.

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Robert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's buiRobert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case,

From: Robert Stryker <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Cc: Carl Anderson <[hidden email]>, Nitin Dahyabhai <[hidden email]>, Keith Chong <[hidden email]>, Victor Rubezhny <[hidden email]>
Date: 01/29/2018 11:46 AM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build





Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case, m4?)

The issue seems to be that When installing WTP 3.10.M5 smoke test candidate, could not find org.eclipse.jetty.webapp [9.4.7,10.0.0).  Servertools seems to need this library and cannot find it.

Even though the UI insists it won't install servertools, it still does, but it installs a lower version than expected.

696    STARTING    org.eclipse.wst.server.core_1.10.0.v201705172051
697    STARTING    org.eclipse.wst.server.discovery_1.3.100.v201705102053
698    STARTING    org.eclipse.wst.server.ui_1.5.400.v201705172051
699    STARTING    org.eclipse.wst.server.ui.doc.user_1.1.600.v201309182117
700    RESOLVED    org.eclipse.wst.server.ui.infopop_1.1.200.v201309182117

This is pretty confusing for me. Remediation insisted it would not install it, but it installed it anyway, but somehow found a downgraded version despite using the http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/repository/  update site.

Very weird behavior

- Rob

On Fri, Jan 26, 2018 at 4:44 PM, Nick Boldt <[hidden email]> wrote:
    And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

    [DEBUG] Closing connection to remote
    [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure:
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46]
    [ERROR] lastTransformerInChain.getSerializationHandler().flushPending();
    [ERROR]                        ^^^^^^^^^^^^^^^^^^^^^^^
    [ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131]
    [ERROR] currentLine = e.m_styleNode.getEndLineNumber();
    [ERROR]                             ^^^^^^^^^^^^^^^^
    [ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
    [ERROR] 2 problems (2 errors)


    Back to you in the studio, sourceediting folks.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



    On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
    I pulled in the latest commits from these 4 repos:

    * 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

    Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/235/parameters/


    On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:
      Nick,

      We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)


      FWIW,


      - Carl Anderson
      WTP Releng project lead


      Inactive hide details for Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to bNick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

      From:
      Nick Boldt <[hidden email]>
      To:
      Webtools releng discussion list <[hidden email]>
      Date:
      01/25/2018 04:52 PM
      Subject:
      Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
      Sent by:
      [hidden email]





      Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

       == webtools.javaee == 
      * 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
      * ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
      * 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

       == webtools.jsdt == 
      * d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

       == webtools.jsf == 
      * 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

       == webtools.sourceediting == 
      * a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
      * b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
      * 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

      Should these be included in M5? If so, we need a respin.

      On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:


      --
      Nick Boldt
      Senior Software Engineer, RHCSA
      Productization Lead :: JBoss Tools & Dev Studio
      IM: @nickboldt / @nboldt /
      http://nick.divbyzero.com
TRIED. TESTED. TRUSTED.

TRIED. TESTED. TRUSTED.



    --
    Nick Boldt
    Senior Software Engineer, RHCSA
    Productization Lead :: JBoss Tools & Dev Studio
    IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.





_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Nick Boldt-3
Confirmed. To install this build you need to first add a link to the Jetty 9.4.7 site [1] in your Eclipse.


However I'm also seeing remediation trying to install this:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
  Software being installed: Eclipse Web Developer Tools 3.9.2.v201801221842 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201801221842)
  Only one of the following can be installed at once: 
    Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
    Server Core 1.10.0.v201705172051 (org.eclipse.wst.server.core 1.10.0.v201705172051)

I'll look into WHY we have two versions of that plugin in the repo... we shouldn't have both.



On Mon, Jan 29, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:

Folks,

This was all caused by Nick's fix to bug 527813 , which moved WTP from including the two Jetty plugins that the Platform does not ship, to simply requiring those plugins. BIRT includes the 9.4.5 version of those plugins (yet, the platform, and WTP, moved up to Jetty 9.4.7 for Oxygen.2 and Photon M4). If you look at comment #31 on that bug, you will find the link to the repo that you need to add in order to resolve this dependency during WTP's install.

Nick,

Due to issues that have arisen with adopters using Oxygen.2 and everyone using Photon M5, should we revisit the decision to move this from an include to a require? Right now, WTP is at the mercy of other teams like BIRT, which includes the 9.4.5 versions of these Jetty plugins in Photon. The Eclipse Platform does not include all of the Jetty plugins that WTP requires, and there is no direct contribution of the Jetty plugins to the simultaneous release aggregation. From a release engineering standpoint, this is not ideal.

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Robert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's buiRobert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case,

From: Robert Stryker <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Cc: Carl Anderson <[hidden email]>, Nitin Dahyabhai <[hidden email]>, Keith Chong <[hidden email]>, Victor Rubezhny <[hidden email]>
Date: 01/29/2018 11:46 AM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build





Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case, m4?)

The issue seems to be that When installing WTP 3.10.M5 smoke test candidate, could not find org.eclipse.jetty.webapp [9.4.7,10.0.0).  Servertools seems to need this library and cannot find it.

Even though the UI insists it won't install servertools, it still does, but it installs a lower version than expected.

696    STARTING    org.eclipse.wst.server.core_1.10.0.v201705172051
697    STARTING    org.eclipse.wst.server.discovery_1.3.100.v201705102053
698    STARTING    org.eclipse.wst.server.ui_1.5.400.v201705172051
699    STARTING    org.eclipse.wst.server.ui.doc.user_1.1.600.v201309182117
700    RESOLVED    org.eclipse.wst.server.ui.infopop_1.1.200.v201309182117

This is pretty confusing for me. Remediation insisted it would not install it, but it installed it anyway, but somehow found a downgraded version despite using the http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/repository/  update site.

Very weird behavior

- Rob


On Fri, Jan 26, 2018 at 4:44 PM, Nick Boldt <[hidden email]> wrote:
    And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

    [DEBUG] Closing connection to remote
    [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure:
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46]
    [ERROR] lastTransformerInChain.getSerializationHandler().flushPending();
    [ERROR]                        ^^^^^^^^^^^^^^^^^^^^^^^
    [ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131]
    [ERROR] currentLine = e.m_styleNode.getEndLineNumber();
    [ERROR]                             ^^^^^^^^^^^^^^^^
    [ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
    [ERROR] 2 problems (2 errors)


    Back to you in the studio, sourceediting folks.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



    On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
    I pulled in the latest commits from these 4 repos:

    * 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

    Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/235/parameters/


    On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:
      Nick,

      We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)


      FWIW,


      - Carl Anderson
      WTP Releng project lead


      Inactive hide details for Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to bNick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

      From:
      Nick Boldt <[hidden email]>
      To:
      Webtools releng discussion list <[hidden email]>
      Date:
      01/25/2018 04:52 PM
      Subject:
      Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
      Sent by:
      [hidden email]





      Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

       == webtools.javaee == 
      * 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
      * ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
      * 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

       == webtools.jsdt == 
      * d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

       == webtools.jsf == 
      * 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

       == webtools.sourceediting == 
      * a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
      * b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
      * 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

      Should these be included in M5? If so, we need a respin.

      On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:


      --
      Nick Boldt
      Senior Software Engineer, RHCSA
      Productization Lead :: JBoss Tools & Dev Studio
      IM: @nickboldt / @nboldt /
      http://nick.divbyzero.com
TRIED. TESTED. TRUSTED.

TRIED. TESTED. TRUSTED.



    --
    Nick Boldt
    Senior Software Engineer, RHCSA
    Productization Lead :: JBoss Tools & Dev Studio
    IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.





_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng



--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Nick Boldt-3
I've opened two bugs to track these issues:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=530465 - Remediation presented and two versions of server core in WTP update site 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=530464 - WTP update site should include redistribution of Jetty 9.4.7

I've also opened this issue to track the Xalan debugger / SSE/ Tycho 1.1 issue:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=530467 - compile failed in org/eclipse/wst/xsl/xalan/debugger with Tycho 1.1.0-SNAPSHOT (3.10.0.M5)

Has anyone made any progress on the Xalan issue?

Nick

On Mon, Jan 29, 2018 at 2:36 PM, Nick Boldt <[hidden email]> wrote:
Confirmed. To install this build you need to first add a link to the Jetty 9.4.7 site [1] in your Eclipse.


However I'm also seeing remediation trying to install this:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
  Software being installed: Eclipse Web Developer Tools 3.9.2.v201801221842 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201801221842)
  Only one of the following can be installed at once: 
    Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
    Server Core 1.10.0.v201705172051 (org.eclipse.wst.server.core 1.10.0.v201705172051)

I'll look into WHY we have two versions of that plugin in the repo... we shouldn't have both.



On Mon, Jan 29, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:

Folks,

This was all caused by Nick's fix to bug 527813 , which moved WTP from including the two Jetty plugins that the Platform does not ship, to simply requiring those plugins. BIRT includes the 9.4.5 version of those plugins (yet, the platform, and WTP, moved up to Jetty 9.4.7 for Oxygen.2 and Photon M4). If you look at comment #31 on that bug, you will find the link to the repo that you need to add in order to resolve this dependency during WTP's install.

Nick,

Due to issues that have arisen with adopters using Oxygen.2 and everyone using Photon M5, should we revisit the decision to move this from an include to a require? Right now, WTP is at the mercy of other teams like BIRT, which includes the 9.4.5 versions of these Jetty plugins in Photon. The Eclipse Platform does not include all of the Jetty plugins that WTP requires, and there is no direct contribution of the Jetty plugins to the simultaneous release aggregation. From a release engineering standpoint, this is not ideal.

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Robert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's buiRobert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case,

From: Robert Stryker <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Cc: Carl Anderson <[hidden email]>, Nitin Dahyabhai <[hidden email]>, Keith Chong <[hidden email]>, Victor Rubezhny <[hidden email]>
Date: 01/29/2018 11:46 AM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build





Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case, m4?)

The issue seems to be that When installing WTP 3.10.M5 smoke test candidate, could not find org.eclipse.jetty.webapp [9.4.7,10.0.0).  Servertools seems to need this library and cannot find it.

Even though the UI insists it won't install servertools, it still does, but it installs a lower version than expected.

696    STARTING    org.eclipse.wst.server.core_1.10.0.v201705172051
697    STARTING    org.eclipse.wst.server.discovery_1.3.100.v201705102053
698    STARTING    org.eclipse.wst.server.ui_1.5.400.v201705172051
699    STARTING    org.eclipse.wst.server.ui.doc.user_1.1.600.v201309182117
700    RESOLVED    org.eclipse.wst.server.ui.infopop_1.1.200.v201309182117

This is pretty confusing for me. Remediation insisted it would not install it, but it installed it anyway, but somehow found a downgraded version despite using the http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/repository/  update site.

Very weird behavior

- Rob


On Fri, Jan 26, 2018 at 4:44 PM, Nick Boldt <[hidden email]> wrote:
    And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

    [DEBUG] Closing connection to remote
    [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure:
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46]
    [ERROR] lastTransformerInChain.getSerializationHandler().flushPending();
    [ERROR]                        ^^^^^^^^^^^^^^^^^^^^^^^
    [ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131]
    [ERROR] currentLine = e.m_styleNode.getEndLineNumber();
    [ERROR]                             ^^^^^^^^^^^^^^^^
    [ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
    [ERROR] 2 problems (2 errors)


    Back to you in the studio, sourceediting folks.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



    On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
    I pulled in the latest commits from these 4 repos:

    * 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

    Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/235/parameters/


    On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:
      Nick,

      We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)


      FWIW,


      - Carl Anderson
      WTP Releng project lead


      Inactive hide details for Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to bNick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

      From:
      Nick Boldt <[hidden email]>
      To:
      Webtools releng discussion list <[hidden email]>
      Date:
      01/25/2018 04:52 PM
      Subject:
      Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
      Sent by:
      [hidden email]





      Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

       == webtools.javaee == 
      * 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
      * ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
      * 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

       == webtools.jsdt == 
      * d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

       == webtools.jsf == 
      * 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

       == webtools.sourceediting == 
      * a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
      * b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
      * 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

      Should these be included in M5? If so, we need a respin.

      On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:


      --
      Nick Boldt
      Senior Software Engineer, RHCSA
      Productization Lead :: JBoss Tools & Dev Studio
      IM: @nickboldt / @nboldt /
      http://nick.divbyzero.com
TRIED. TESTED. TRUSTED.

TRIED. TESTED. TRUSTED.



    --
    Nick Boldt
    Senior Software Engineer, RHCSA
    Productization Lead :: JBoss Tools & Dev Studio
    IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.





_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng



--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Nick Boldt-3
Two updates:

a) managed to build WTP integration (releng.aggregator) using Tycho 1.0.0 instead of 1.1.0-SNAPSHOT, despite supposedly needing it for Dali.


b) Posted to the tycho-dev list and Jan suggested the issue in SSE is that we have somehow included two versions of Xalan in the target platform used to build SSE. I'll investigate that today, though I'm not sure how this is happening or why:

"Sounds like you have two versions of xalan in the compilation classpath or in the p2 target platform and it's a matter of chance which one is picked."

Meanwhile I've updated these BZs w/ status:



Nick


On Mon, Jan 29, 2018 at 2:46 PM, Nick Boldt <[hidden email]> wrote:
I've opened two bugs to track these issues:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=530465 - Remediation presented and two versions of server core in WTP update site 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=530464 - WTP update site should include redistribution of Jetty 9.4.7

I've also opened this issue to track the Xalan debugger / SSE/ Tycho 1.1 issue:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=530467 - compile failed in org/eclipse/wst/xsl/xalan/debugger with Tycho 1.1.0-SNAPSHOT (3.10.0.M5)

Has anyone made any progress on the Xalan issue?

Nick

On Mon, Jan 29, 2018 at 2:36 PM, Nick Boldt <[hidden email]> wrote:
Confirmed. To install this build you need to first add a link to the Jetty 9.4.7 site [1] in your Eclipse.


However I'm also seeing remediation trying to install this:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
  Software being installed: Eclipse Web Developer Tools 3.9.2.v201801221842 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201801221842)
  Only one of the following can be installed at once: 
    Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
    Server Core 1.10.0.v201705172051 (org.eclipse.wst.server.core 1.10.0.v201705172051)

I'll look into WHY we have two versions of that plugin in the repo... we shouldn't have both.



On Mon, Jan 29, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:

Folks,

This was all caused by Nick's fix to bug 527813 , which moved WTP from including the two Jetty plugins that the Platform does not ship, to simply requiring those plugins. BIRT includes the 9.4.5 version of those plugins (yet, the platform, and WTP, moved up to Jetty 9.4.7 for Oxygen.2 and Photon M4). If you look at comment #31 on that bug, you will find the link to the repo that you need to add in order to resolve this dependency during WTP's install.

Nick,

Due to issues that have arisen with adopters using Oxygen.2 and everyone using Photon M5, should we revisit the decision to move this from an include to a require? Right now, WTP is at the mercy of other teams like BIRT, which includes the 9.4.5 versions of these Jetty plugins in Photon. The Eclipse Platform does not include all of the Jetty plugins that WTP requires, and there is no direct contribution of the Jetty plugins to the simultaneous release aggregation. From a release engineering standpoint, this is not ideal.

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Robert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's buiRobert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case,

From: Robert Stryker <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Cc: Carl Anderson <[hidden email]>, Nitin Dahyabhai <[hidden email]>, Keith Chong <[hidden email]>, Victor Rubezhny <[hidden email]>
Date: 01/29/2018 11:46 AM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build





Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case, m4?)

The issue seems to be that When installing WTP 3.10.M5 smoke test candidate, could not find org.eclipse.jetty.webapp [9.4.7,10.0.0).  Servertools seems to need this library and cannot find it.

Even though the UI insists it won't install servertools, it still does, but it installs a lower version than expected.

696    STARTING    org.eclipse.wst.server.core_1.10.0.v201705172051
697    STARTING    org.eclipse.wst.server.discovery_1.3.100.v201705102053
698    STARTING    org.eclipse.wst.server.ui_1.5.400.v201705172051
699    STARTING    org.eclipse.wst.server.ui.doc.user_1.1.600.v201309182117
700    RESOLVED    org.eclipse.wst.server.ui.infopop_1.1.200.v201309182117

This is pretty confusing for me. Remediation insisted it would not install it, but it installed it anyway, but somehow found a downgraded version despite using the http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/repository/  update site.

Very weird behavior

- Rob


On Fri, Jan 26, 2018 at 4:44 PM, Nick Boldt <[hidden email]> wrote:
    And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

    [DEBUG] Closing connection to remote
    [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure:
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46]
    [ERROR] lastTransformerInChain.getSerializationHandler().flushPending();
    [ERROR]                        ^^^^^^^^^^^^^^^^^^^^^^^
    [ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131]
    [ERROR] currentLine = e.m_styleNode.getEndLineNumber();
    [ERROR]                             ^^^^^^^^^^^^^^^^
    [ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
    [ERROR] 2 problems (2 errors)


    Back to you in the studio, sourceediting folks.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



    On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
    I pulled in the latest commits from these 4 repos:

    * 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

    Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/235/parameters/


    On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:
      Nick,

      We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)


      FWIW,


      - Carl Anderson
      WTP Releng project lead


      Inactive hide details for Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to bNick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

      From:
      Nick Boldt <[hidden email]>
      To:
      Webtools releng discussion list <[hidden email]>
      Date:
      01/25/2018 04:52 PM
      Subject:
      Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
      Sent by:
      [hidden email]





      Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

       == webtools.javaee == 
      * 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
      * ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
      * 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

       == webtools.jsdt == 
      * d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

       == webtools.jsf == 
      * 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

       == webtools.sourceediting == 
      * a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
      * b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
      * 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

      Should these be included in M5? If so, we need a respin.

      On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:


      --
      Nick Boldt
      Senior Software Engineer, RHCSA
      Productization Lead :: JBoss Tools & Dev Studio
      IM: @nickboldt / @nboldt /
      http://nick.divbyzero.com
TRIED. TESTED. TRUSTED.

TRIED. TESTED. TRUSTED.



    --
    Nick Boldt
    Senior Software Engineer, RHCSA
    Productization Lead :: JBoss Tools & Dev Studio
    IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.





_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng



--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Nick Boldt-3
Further update:

* still ZERO response from Dali (on this or the 3.9.3 build)

* webservices move & merge is complete; however we've hit some build issues as a result

* old enterprise features moved from javaee to webservices can now be disabled/deprecated from the javaee repo [1]

* Photon M5 staging site has been declared, so we missed the boat here. 

For M6, can we do the smoke test more in advance of the cutoff, so there's more time for testing and for everyone to respond? Seems Thurs-Tues was not enough time. How about a full week (or two?) in advance? 

Could we also mandate that every team lead sign into Mattermost "webtools" channel so they're easily reachable for comments / feedback / gerrit reviews & merges? Keith's been amazing this week, and Nitin & Rob are always in there, but there are others that are REALLY difficult to reach. 






On Tue, Jan 30, 2018 at 9:43 AM, Nick Boldt <[hidden email]> wrote:
Two updates:

a) managed to build WTP integration (releng.aggregator) using Tycho 1.0.0 instead of 1.1.0-SNAPSHOT, despite supposedly needing it for Dali.


b) Posted to the tycho-dev list and Jan suggested the issue in SSE is that we have somehow included two versions of Xalan in the target platform used to build SSE. I'll investigate that today, though I'm not sure how this is happening or why:

"Sounds like you have two versions of xalan in the compilation classpath or in the p2 target platform and it's a matter of chance which one is picked."

Meanwhile I've updated these BZs w/ status:



Nick


On Mon, Jan 29, 2018 at 2:46 PM, Nick Boldt <[hidden email]> wrote:
I've opened two bugs to track these issues:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=530465 - Remediation presented and two versions of server core in WTP update site 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=530464 - WTP update site should include redistribution of Jetty 9.4.7

I've also opened this issue to track the Xalan debugger / SSE/ Tycho 1.1 issue:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=530467 - compile failed in org/eclipse/wst/xsl/xalan/debugger with Tycho 1.1.0-SNAPSHOT (3.10.0.M5)

Has anyone made any progress on the Xalan issue?

Nick

On Mon, Jan 29, 2018 at 2:36 PM, Nick Boldt <[hidden email]> wrote:
Confirmed. To install this build you need to first add a link to the Jetty 9.4.7 site [1] in your Eclipse.


However I'm also seeing remediation trying to install this:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
  Software being installed: Eclipse Web Developer Tools 3.9.2.v201801221842 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201801221842)
  Only one of the following can be installed at once: 
    Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
    Server Core 1.10.0.v201705172051 (org.eclipse.wst.server.core 1.10.0.v201705172051)

I'll look into WHY we have two versions of that plugin in the repo... we shouldn't have both.



On Mon, Jan 29, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:

Folks,

This was all caused by Nick's fix to bug 527813 , which moved WTP from including the two Jetty plugins that the Platform does not ship, to simply requiring those plugins. BIRT includes the 9.4.5 version of those plugins (yet, the platform, and WTP, moved up to Jetty 9.4.7 for Oxygen.2 and Photon M4). If you look at comment #31 on that bug, you will find the link to the repo that you need to add in order to resolve this dependency during WTP's install.

Nick,

Due to issues that have arisen with adopters using Oxygen.2 and everyone using Photon M5, should we revisit the decision to move this from an include to a require? Right now, WTP is at the mercy of other teams like BIRT, which includes the 9.4.5 versions of these Jetty plugins in Photon. The Eclipse Platform does not include all of the Jetty plugins that WTP requires, and there is no direct contribution of the Jetty plugins to the simultaneous release aggregation. From a release engineering standpoint, this is not ideal.

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Robert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's buiRobert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case,

From: Robert Stryker <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Cc: Carl Anderson <[hidden email]>, Nitin Dahyabhai <[hidden email]>, Keith Chong <[hidden email]>, Victor Rubezhny <[hidden email]>
Date: 01/29/2018 11:46 AM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build





Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case, m4?)

The issue seems to be that When installing WTP 3.10.M5 smoke test candidate, could not find org.eclipse.jetty.webapp [9.4.7,10.0.0).  Servertools seems to need this library and cannot find it.

Even though the UI insists it won't install servertools, it still does, but it installs a lower version than expected.

696    STARTING    org.eclipse.wst.server.core_1.10.0.v201705172051
697    STARTING    org.eclipse.wst.server.discovery_1.3.100.v201705102053
698    STARTING    org.eclipse.wst.server.ui_1.5.400.v201705172051
699    STARTING    org.eclipse.wst.server.ui.doc.user_1.1.600.v201309182117
700    RESOLVED    org.eclipse.wst.server.ui.infopop_1.1.200.v201309182117

This is pretty confusing for me. Remediation insisted it would not install it, but it installed it anyway, but somehow found a downgraded version despite using the http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/repository/  update site.

Very weird behavior

- Rob


On Fri, Jan 26, 2018 at 4:44 PM, Nick Boldt <[hidden email]> wrote:
    And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

    [DEBUG] Closing connection to remote
    [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure:
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46]
    [ERROR] lastTransformerInChain.getSerializationHandler().flushPending();
    [ERROR]                        ^^^^^^^^^^^^^^^^^^^^^^^
    [ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131]
    [ERROR] currentLine = e.m_styleNode.getEndLineNumber();
    [ERROR]                             ^^^^^^^^^^^^^^^^
    [ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
    [ERROR] 2 problems (2 errors)


    Back to you in the studio, sourceediting folks.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



    On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
    I pulled in the latest commits from these 4 repos:

    * 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

    Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/235/parameters/


    On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:
      Nick,

      We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)


      FWIW,


      - Carl Anderson
      WTP Releng project lead


      Inactive hide details for Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to bNick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

      From:
      Nick Boldt <[hidden email]>
      To:
      Webtools releng discussion list <[hidden email]>
      Date:
      01/25/2018 04:52 PM
      Subject:
      Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
      Sent by:
      [hidden email]





      Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

       == webtools.javaee == 
      * 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
      * ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
      * 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

       == webtools.jsdt == 
      * d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

       == webtools.jsf == 
      * 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

       == webtools.sourceediting == 
      * a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
      * b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
      * 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

      Should these be included in M5? If so, we need a respin.

      On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote:


      --
      Nick Boldt
      Senior Software Engineer, RHCSA
      Productization Lead :: JBoss Tools & Dev Studio
      IM: @nickboldt / @nboldt /
      http://nick.divbyzero.com
TRIED. TESTED. TRUSTED.

TRIED. TESTED. TRUSTED.



    --
    Nick Boldt
    Senior Software Engineer, RHCSA
    Productization Lead :: JBoss Tools & Dev Studio
    IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.





_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng



--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Neil Hauge
Nick,

Dali signed off on 393 smoke yesterday.  Not sure what you are looking for regarding Dali response for this thread.

Neil

On Feb 1, 2018, at 9:17 AM, Nick Boldt <[hidden email]> wrote:

Further update:

* still ZERO response from Dali (on this or the 3.9.3 build)

* webservices move & merge is complete; however we've hit some build issues as a result

* old enterprise features moved from javaee to webservices can now be disabled/deprecated from the javaee repo [1]

* Photon M5 staging site has been declared, so we missed the boat here. 

For M6, can we do the smoke test more in advance of the cutoff, so there's more time for testing and for everyone to respond? Seems Thurs-Tues was not enough time. How about a full week (or two?) in advance? 

Could we also mandate that every team lead sign into Mattermost "webtools" channel so they're easily reachable for comments / feedback / gerrit reviews & merges? Keith's been amazing this week, and Nitin & Rob are always in there, but there are others that are REALLY difficult to reach. 






On Tue, Jan 30, 2018 at 9:43 AM, Nick Boldt <[hidden email]> wrote:
Two updates:

a) managed to build WTP integration (releng.aggregator) using Tycho 1.0.0 instead of 1.1.0-SNAPSHOT, despite supposedly needing it for Dali.


b) Posted to the tycho-dev list and Jan suggested the issue in SSE is that we have somehow included two versions of Xalan in the target platform used to build SSE. I'll investigate that today, though I'm not sure how this is happening or why:

"Sounds like you have two versions of xalan in the compilation classpath or in the p2 target platform and it's a matter of chance which one is picked."

Meanwhile I've updated these BZs w/ status:



Nick


On Mon, Jan 29, 2018 at 2:46 PM, Nick Boldt <[hidden email]> wrote:
I've opened two bugs to track these issues:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=530465 - Remediation presented and two versions of server core in WTP update site 
https://bugs.eclipse.org/bugs/show_bug.cgi?id=530464 - WTP update site should include redistribution of Jetty 9.4.7

I've also opened this issue to track the Xalan debugger / SSE/ Tycho 1.1 issue:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=530467 - compile failed in org/eclipse/wst/xsl/xalan/debugger with Tycho 1.1.0-SNAPSHOT (3.10.0.M5)

Has anyone made any progress on the Xalan issue?

Nick

On Mon, Jan 29, 2018 at 2:36 PM, Nick Boldt <[hidden email]> wrote:
Confirmed. To install this build you need to first add a link to the Jetty 9.4.7 site [1] in your Eclipse.


However I'm also seeing remediation trying to install this:

Cannot complete the install because of a conflicting dependency.
  Software being installed: Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
  Software being installed: Eclipse Web Developer Tools 3.9.2.v201801221842 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201801221842)
  Only one of the following can be installed at once: 
    Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
    Server Core 1.10.0.v201705172051 (org.eclipse.wst.server.core 1.10.0.v201705172051)

I'll look into WHY we have two versions of that plugin in the repo... we shouldn't have both.



On Mon, Jan 29, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:

Folks,

This was all caused by Nick's fix to bug 527813 , which moved WTP from including the two Jetty plugins that the Platform does not ship, to simply requiring those plugins. BIRT includes the 9.4.5 version of those plugins (yet, the platform, and WTP, moved up to Jetty 9.4.7 for Oxygen.2 and Photon M4). If you look at comment #31 on that bug, you will find the link to the repo that you need to add in order to resolve this dependency during WTP's install.

Nick,

Due to issues that have arisen with adopters using Oxygen.2 and everyone using Photon M5, should we revisit the decision to move this from an include to a require? Right now, WTP is at the mercy of other teams like BIRT, which includes the 9.4.5 versions of these Jetty plugins in Photon. The Eclipse Platform does not include all of the Jetty plugins that WTP requires, and there is no direct contribution of the Jetty plugins to the simultaneous release aggregation. From a release engineering standpoint, this is not ideal.

FWIW,

- Carl Anderson
WTP Releng project lead

<graycol.gif>Robert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case,

From:  Robert Stryker <[hidden email]>
To:  Webtools releng discussion list <[hidden email]>
Cc:  Carl Anderson <[hidden email]>, Nitin Dahyabhai <[hidden email]>, Keith Chong <[hidden email]>, Victor Rubezhny <[hidden email]>
Date:  01/29/2018 11:46 AM
Subject:  Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build





Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case, m4?)

The issue seems to be that When installing WTP 3.10.M5 smoke test candidate, could not find org.eclipse.jetty.webapp [9.4.7,10.0.0).  Servertools seems to need this library and cannot find it. 

Even though the UI insists it won't install servertools, it still does, but it installs a lower version than expected. 

696    STARTING    org.eclipse.wst.server.core_1.10.0.v201705172051
697    STARTING    org.eclipse.wst.server.discovery_1.3.100.v201705102053
698    STARTING    org.eclipse.wst.server.ui_1.5.400.v201705172051
699    STARTING    org.eclipse.wst.server.ui.doc.user_1.1.600.v201309182117
700    RESOLVED    org.eclipse.wst.server.ui.infopop_1.1.200.v201309182117

This is pretty confusing for me. Remediation insisted it would not install it, but it installed it anyway, but somehow found a downgraded version despite using the http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/repository/  update site. 

Very weird behavior

- Rob


On Fri, Jan 26, 2018 at 4:44 PM, Nick Boldt <[hidden email]> wrote:
    And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

    [DEBUG] Closing connection to remote
    [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure: 
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46] 
    [ERROR] lastTransformerInChain.getSerializationHandler().flushPending();
    [ERROR]                        ^^^^^^^^^^^^^^^^^^^^^^^
    [ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
    [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131] 
    [ERROR] currentLine = e.m_styleNode.getEndLineNumber();
    [ERROR]                             ^^^^^^^^^^^^^^^^
    [ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
    [ERROR] 2 problems (2 errors)


    Back to you in the studio, sourceediting folks.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



    On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
    I pulled in the latest commits from these 4 repos:

    * 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

    Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.

    https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/235/parameters/


    On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:
      Nick,

      We need to respin WTP 3.10.0 on top of the Eclipse Platform M5 driver (and keep it building on M5 until after we declare our M5 driver). As such, we need a respin, and can pick up these changes at the same time. (Almost all of these are changes that should not effect the smoke test itself- moving features from repo to repo. Only the Bug 503733 change looks like it could impact things.)


      FWIW,


      - Carl Anderson
      WTP Releng project lead


      <graycol.gif>Nick Boldt ---01/25/2018 04:52:30 PM---Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the late

      From: 
      Nick Boldt <[hidden email]>
      To: 
      Webtools releng discussion list <[hidden email]>
      Date: 
      01/25/2018 04:52 PM
      Subject: 
      Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
      Sent by: 
      [hidden email]





      Missing recent commits (because the releng.aggregator has to be MANUALLY updated to pull in the latest bits from the submodules):

       == webtools.javaee == 
      * 4e7cbc935 - (HEAD -> master, origin/master, origin/HEAD) 528792 add README.deprecated.txt notes to the features that moved to webservices [hidden email] (6 hours ago)
      * ec9418e73 - add org.eclipse.jst.ejb.doc.user to webtools.javaee update site so it's accessible from webservices build [hidden email] (31 hours ago)
      * 69bbacf16 - Bug 503733 - Concurrent modification exceptions in JEE5ModelProvider [hidden email] (2 days ago)

       == webtools.jsdt == 
      * d905e75a6 - (HEAD -> master, origin/master, origin/HEAD) add bundle org.eclipse.wst.jsdt.debug.rhino.ui to webtools.jsdt update site, since required by downstream webservices repo : org.eclipse.jst.web_ui.feature.feature.group [hidden email] (2 days ago)

       == webtools.jsf == 
      * 490184c2 - (HEAD -> master, origin/master, origin/HEAD) add jar files to .gitignore [hidden email] (2 days ago)

       == webtools.sourceediting == 
      * a6b967229 - (HEAD -> master) add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (9 minutes ago)
      * b83ce57d1 - (origin/master, origin/HEAD) remove unused @buildversionid@; add org.eclipse.jst.jsp.core.tests so it can be seen by downstream repos [hidden email] (26 hours ago)
      * 696128a0b - add org.eclipse.jst.jsp.core.source and org.eclipse.jst.jsp.ui.source to update site [hidden email] (3 days ago)

      Should these be included in M5? If so, we need a respin.

      On Thu, Jan 25, 2018 at 9:29 AM, Carl Anderson <[hidden email]> wrote: 


      -- 
      Nick Boldt
      Senior Software Engineer, RHCSA
      Productization Lead :: JBoss Tools & Dev Studio
      IM: @nickboldt / @nboldt / 
      http://nick.divbyzero.com
TRIED. TESTED. TRUSTED.

TRIED. TESTED. TRUSTED.



    -- 
    Nick Boldt
    Senior Software Engineer, RHCSA
    Productization Lead :: JBoss Tools & Dev Studio
    IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.






_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng



-- 
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




-- 
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




-- 
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com




-- 
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com

_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=UEDMFaPBmz1R1yyN9qnqq29XIVsfdyd_8HRm_xxS08g&m=AuIaHKvuPNcJqT7YxqKTO3OSIUt5tBX2uys4kgM369c&s=7-4GmWbDLwT5OD8zR-2q3_jfmrWTzTkmRrLpRXGRVjo&e=


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Carl Anderson
In reply to this post by Nick Boldt-3

Nick,

First, Dali did update the 3.9.3 smoketest page yesterday- please declare/publish the build to download.eclipse.org as soon as possible.
Second, rather than trying to do the M6 smoketest early, I would state that we need to get regular (every two week) declares of WTP 3.10.0. So far, we've had one successful smoketest, and we've had a lot of build churn and feature/plugin movement that have really made things unstable. I would prefer to get these issues resolved before/during the smoke tests leading up to M6, rather than extend the length of the smoketest for M6. (In reality, our smoke tests are only supposed to last one day- issued Thursday morning, declared Friday... but for milestones/releases, it is extended in order to respin on top of prereqs... for example, the platform declares their milestone/release candidate the day after our smoke test begins. Other prereqs can change on Monday, on their +1 day. So we need to hold off declaring until then.)
Thanks again for all of your hard work getting us set up better for CBI and Unit tests.

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Nick Boldt ---02/01/2018 09:18:25 AM---Further update: * still ZERO response from Dali (on this or thNick Boldt ---02/01/2018 09:18:25 AM---Further update: * still ZERO response from Dali (on this or the 3.9.3 build)

From: Nick Boldt <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Date: 02/01/2018 09:18 AM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
Sent by: [hidden email]





Further update:

* still ZERO response from Dali (on this or the 3.9.3 build)

* webservices move & merge is complete; however we've hit some build issues as a result

* old enterprise features moved from javaee to webservices can now be disabled/deprecated from the javaee repo [1]

* Photon M5 staging site has been declared, so we missed the boat here. 

For M6, can we do the smoke test more in advance of the cutoff, so there's more time for testing and for everyone to respond? Seems Thurs-Tues was not enough time. How about a full week (or two?) in advance? 

Could we also mandate that every team lead sign into Mattermost "webtools" channel so they're easily reachable for comments / feedback / gerrit reviews & merges? Keith's been amazing this week, and Nitin & Rob are always in there, but there are others that are REALLY difficult to reach. 

[1] https://git.eclipse.org/r/#/c/116062/





On Tue, Jan 30, 2018 at 9:43 AM, Nick Boldt <[hidden email]> wrote:
    Two updates:

    a) managed to build WTP integration (releng.aggregator) using Tycho 1.0.0 instead of 1.1.0-SNAPSHOT, despite supposedly needing it for Dali.

    Build: https://hudson.eclipse.org/webtools/job/WTP-R3_10_Integration/244/
    Results: http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180129161428/I-3.10.0-20180129161428/
    Repo: http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180129161428/I-3.10.0-20180129161428/repository/

    b) Posted to the tycho-dev list and Jan suggested the issue in SSE is that we have somehow included two versions of Xalan in the target platform used to build SSE. I'll investigate that today, though I'm not sure how this is happening or why:

    "Sounds like you have two versions of xalan in the compilation classpath or in the p2 target platform and it's a matter of chance which one is picked."

    Meanwhile I've updated these BZs w/ status:

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530467
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530465
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530464


    Nick


    On Mon, Jan 29, 2018 at 2:46 PM, Nick Boldt <[hidden email]> wrote:
    I've opened two bugs to track these issues:

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530465 - Remediation presented and two versions of server core in WTP update site 
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530464 - WTP update site should include redistribution of Jetty 9.4.7

    I've also opened this issue to track the Xalan debugger / SSE/ Tycho 1.1 issue:

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530467 - compile failed in org/eclipse/wst/xsl/xalan/debugger with Tycho 1.1.0-SNAPSHOT (3.10.0.M5)

    Has anyone made any progress on the Xalan issue?

    Nick

    On Mon, Jan 29, 2018 at 2:36 PM, Nick Boldt <[hidden email]> wrote:
      Confirmed. To install this build you need to first add a link to the Jetty 9.4.7 site [1] in your Eclipse.

      [1] http://download.eclipse.org/jetty/updates/jetty-bundles-9.x/9.4.7.v20170914/

      However I'm also seeing remediation trying to install this:

      Cannot complete the install because of a conflicting dependency.
        Software being installed: Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
        Software being installed: Eclipse Web Developer Tools 3.9.2.v201801221842 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201801221842)
        Only one of the following can be installed at once: 
          Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
          Server Core 1.10.0.v201705172051 (org.eclipse.wst.server.core 1.10.0.v201705172051)

      I'll look into WHY we have two versions of that plugin in the repo... we shouldn't have both.



      On Mon, Jan 29, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:
      Folks,

      This was all caused by Nick's fix to bug 527813 , which moved WTP from including the two Jetty plugins that the Platform does not ship, to simply requiring those plugins. BIRT includes the 9.4.5 version of those plugins (yet, the platform, and WTP, moved up to Jetty 9.4.7 for Oxygen.2 and Photon M4). If you look at comment #31 on that bug, you will find the link to the repo that you need to add in order to resolve this dependency during WTP's install.


      Nick,


      Due to issues that have arisen with adopters using Oxygen.2 and everyone using Photon M5, should we revisit the decision to move this from an include to a require? Right now, WTP is at the mercy of other teams like BIRT, which includes the 9.4.5 versions of these Jetty plugins in Photon. The Eclipse Platform does not include all of the Jetty plugins that WTP requires, and there is no direct contribution of the Jetty plugins to the simultaneous release aggregation. From a release engineering standpoint, this is not ideal.


      FWIW,


      - Carl Anderson
      WTP Releng project lead


      Inactive hide details for Robert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's buiRobert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case,

      From:
      Robert Stryker <[hidden email]>
      To:
      Webtools releng discussion list <[hidden email]>
      Cc:
      Carl Anderson <[hidden email]>, Nitin Dahyabhai <[hidden email]>, Keith Chong <[hidden email]>, Victor Rubezhny <[hidden email]>
      Date:
      01/29/2018 11:46 AM
      Subject:
      Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build




      Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case, m4?)

      The issue seems to be that When installing WTP 3.10.M5 smoke test candidate, could not find org.eclipse.jetty.webapp [9.4.7,10.0.0).  Servertools seems to need this library and cannot find it.

      Even though the UI insists it won't install servertools, it still does, but it installs a lower version than expected.

      696    STARTING    org.eclipse.wst.server.core_1.10.0.v201705172051
      697    STARTING    org.eclipse.wst.server.discovery_1.3.100.v201705102053
      698    STARTING    org.eclipse.wst.server.ui_1.5.400.v201705172051
      699    STARTING    org.eclipse.wst.server.ui.doc.user_1.1.600.v201309182117
      700    RESOLVED    org.eclipse.wst.server.ui.infopop_1.1.200.v201309182117

      This is pretty confusing for me. Remediation insisted it would not install it, but it installed it anyway, but somehow found a downgraded version despite using the http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/repository/  update site.

      Very weird behavior

      - Rob


      On Fri, Jan 26, 2018 at 4:44 PM, Nick Boldt <[hidden email]> wrote:
          And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

          [DEBUG] Closing connection to remote
          [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure:
          [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46]
          [ERROR] lastTransformerInChain.getSerializationHandler().flushPending();
          [ERROR]                        ^^^^^^^^^^^^^^^^^^^^^^^
          [ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
          [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131]
          [ERROR] currentLine = e.m_styleNode.getEndLineNumber();
          [ERROR]                             ^^^^^^^^^^^^^^^^
          [ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
          [ERROR] 2 problems (2 errors)


          Back to you in the studio, sourceediting folks.


          https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



          On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
          I pulled in the latest commits from these 4 repos:

          * 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

          Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.

          https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/235/parameters/


          On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:



          --
          Nick Boldt
          Senior Software Engineer, RHCSA
          Productization Lead :: JBoss Tools & Dev Studio
          IM: @nickboldt / @nboldt /
          http://nick.divbyzero.com
      TRIED. TESTED. TRUSTED.
      TRIED. TESTED. TRUSTED.





      _______________________________________________
      wtp-releng mailing list
      [hidden email]
      To change your delivery options, retrieve your password, or unsubscribe from this list, visit
      https://dev.eclipse.org/mailman/listinfo/wtp-releng



      --
      Nick Boldt
      Senior Software Engineer, RHCSA
      Productization Lead :: JBoss Tools & Dev Studio
      IM: @nickboldt / @nboldt / http://nick.divbyzero.com
TRIED. TESTED. TRUSTED.

TRIED. TESTED. TRUSTED.



    --
    Nick Boldt
    Senior Software Engineer, RHCSA
    Productization Lead :: JBoss Tools & Dev Studio
    IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.



--
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio
IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.
@ @redhatnews      Red Hat
_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
<a href="https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6JCYBixIS0G6Rj43h5xZSA&m=FWf-wSfe1YZvU55jytAPBda4PkCnpZrdTv2TQl9EGpY&s=1rh4Yx6SqZIXwkN1LJRgeZDdr5E5xq3EJJYUEGvBoGg& e=">https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6JCYBixIS0G6Rj43h5xZSA&m=FWf-wSfe1YZvU55jytAPBda4PkCnpZrdTv2TQl9EGpY&s=1rh4Yx6SqZIXwkN1LJRgeZDdr5E5xq3EJJYUEGvBoGg&e=



_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng
Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Carl Anderson
In reply to this post by Carl Anderson

Folks,

As Nick mentioned in another note, we missed the M5 deadline. As such, this smoke test has officially ended. Committers are free to commit updates to master.

FWIW,

- Carl Anderson
WTP PMC lead

Inactive hide details for "Carl Anderson" ---01/25/2018 09:35:36 AM---Smoke Test Request for WTP 3.10.0 I-build Please document"Carl Anderson" ---01/25/2018 09:35:36 AM---Smoke Test Request for WTP 3.10.0 I-build Please document your Project's testing and approval of thi

From: "Carl Anderson" <[hidden email]>
To: "Webtools releng discussion list" <[hidden email]>
Date: 01/25/2018 09:35 AM
Subject: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
Sent by: [hidden email]




Smoke Test Request for WTP 3.10.0 I-build

Please document your Project's testing and approval of this build,
by 5 PM EDT Monday, or let us know if that's not possible.


Current Build

http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/

Smoketest Results

https://wiki.eclipse.org/WTP_Smoke_Test_Results_R3100_01252018

FWIW,


- Carl Anderson
WTP Build guy

_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6JCYBixIS0G6Rj43h5xZSA&m=SoULd0jpzWtoRQPD3JbhhrRae5y-SCwadR0SxT19fME&s=i1PL-2RgHBl2QuB5cHjt4_FVH0ZReWrMCQkwrsoOdTM&e=



_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng

Reply | Threaded
Open this post in threaded view
|

Re: Smoke Test Request for WTP 3.10.0 I-build

Nick Boldt-3
In reply to this post by Carl Anderson
Apologies to Neil & the Dali team - when last I looked at the 3.9.3 page it hadn't been updated - I guess it was updated a couple hours later according to the wiki history. This process of having to hunt for checkmarks seems needlessly difficult. Why can't we just assume the smoke passes unless someone announces on this list that there's a problem before a predefined cutoff time? If we all know there's a smoke test coming, surely we can plan to allocate an hour in a 24hr period to do the smoke test? What if we announced the smoke test further in advance, so people can better plan?

In JBoss Tools, we announce a code freeze a few days before the Wed at the end of our 3-week sprints, build the final build on the Thursday, and it's ready for testing/smoke/staging/integration by noon on Thursday, giving people a few days to test it (and call for a respin if needed) before it's released the following Tuesday. This would align well with the Tuesday +2 dates for Oxygen and Photon milestones/RCs. 

Where we're different from WTP is that we assume all is green unless someone (usually dev or QE) calls for a respin between the Wed code freeze and the Tuesday release day. 

---- 

Regarding the build churn, yes, I agree that was unfortunate. That was partly caused by changes in M5 / Tycho 1.1, which I'm still solving. I hope there won't be any more breaking changes for M6, but I'll work more closely with mistria and akurtakov to find out if things are in the pipeline which could impact us. Being forced to move to Tycho 1.1 (because of Dali, platform M5, and Webservices) introduced new issues since Tycho 1.1 is more strict about how it validates source feature/plugin generation. So expect more gerrits to fix that, coming soon. 

Some of the M5 build churn was also caused by stalled gerrits. For example, there's a broken test in servertools [1] which I attempted to disable since it's testing an obsolete/deprecated update site format for wtp server adapter discovery, and which once merged, will result in more passing gerrits for servertools. This gerrit has been sitting waiting for review and merge since Jan 15. Two weeks should be unacceptable at any time, but is particularly painful during a milestone smoketest & release period. 


What can we do to prevent these stalls in future? I have some ideas, but I'm wondering what you all think we could do. 

Thanks,

Nick


On Thu, Feb 1, 2018 at 2:01 PM, Carl Anderson <[hidden email]> wrote:

Nick,

First, Dali did update the 3.9.3 smoketest page yesterday- please declare/publish the build to download.eclipse.org as soon as possible.
Second, rather than trying to do the M6 smoketest early, I would state that we need to get regular (every two week) declares of WTP 3.10.0. So far, we've had one successful smoketest, and we've had a lot of build churn and feature/plugin movement that have really made things unstable. I would prefer to get these issues resolved before/during the smoke tests leading up to M6, rather than extend the length of the smoketest for M6. (In reality, our smoke tests are only supposed to last one day- issued Thursday morning, declared Friday... but for milestones/releases, it is extended in order to respin on top of prereqs... for example, the platform declares their milestone/release candidate the day after our smoke test begins. Other prereqs can change on Monday, on their +1 day. So we need to hold off declaring until then.)
Thanks again for all of your hard work getting us set up better for CBI and Unit tests.

FWIW,

- Carl Anderson
WTP Releng project lead

Inactive hide details for Nick Boldt ---02/01/2018 09:18:25 AM---Further update: * still ZERO response from Dali (on this or thNick Boldt ---02/01/2018 09:18:25 AM---Further update: * still ZERO response from Dali (on this or the 3.9.3 build)

From: Nick Boldt <[hidden email]>
To: Webtools releng discussion list <[hidden email]>
Date: 02/01/2018 09:18 AM
Subject: Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build
Sent by: [hidden email]





Further update:

* still ZERO response from Dali (on this or the 3.9.3 build)

* webservices move & merge is complete; however we've hit some build issues as a result

* old enterprise features moved from javaee to webservices can now be disabled/deprecated from the javaee repo [1]

* Photon M5 staging site has been declared, so we missed the boat here. 

For M6, can we do the smoke test more in advance of the cutoff, so there's more time for testing and for everyone to respond? Seems Thurs-Tues was not enough time. How about a full week (or two?) in advance? 

Could we also mandate that every team lead sign into Mattermost "webtools" channel so they're easily reachable for comments / feedback / gerrit reviews & merges? Keith's been amazing this week, and Nitin & Rob are always in there, but there are others that are REALLY difficult to reach. 

[1] https://git.eclipse.org/r/#/c/116062/





On Tue, Jan 30, 2018 at 9:43 AM, Nick Boldt <[hidden email]> wrote:
    Two updates:

    a) managed to build WTP integration (releng.aggregator) using Tycho 1.0.0 instead of 1.1.0-SNAPSHOT, despite supposedly needing it for Dali.

    Build: https://hudson.eclipse.org/webtools/job/WTP-R3_10_Integration/244/
    Results: http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180129161428/I-3.10.0-20180129161428/
    Repo: http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180129161428/I-3.10.0-20180129161428/repository/

    b) Posted to the tycho-dev list and Jan suggested the issue in SSE is that we have somehow included two versions of Xalan in the target platform used to build SSE. I'll investigate that today, though I'm not sure how this is happening or why:

    "Sounds like you have two versions of xalan in the compilation classpath or in the p2 target platform and it's a matter of chance which one is picked."

    Meanwhile I've updated these BZs w/ status:

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530467
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530465
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530464


    Nick


    On Mon, Jan 29, 2018 at 2:46 PM, Nick Boldt <[hidden email]> wrote:
    I've opened two bugs to track these issues:

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530465 - Remediation presented and two versions of server core in WTP update site 
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530464 - WTP update site should include redistribution of Jetty 9.4.7

    I've also opened this issue to track the Xalan debugger / SSE/ Tycho 1.1 issue:

    https://bugs.eclipse.org/bugs/show_bug.cgi?id=530467 - compile failed in org/eclipse/wst/xsl/xalan/debugger with Tycho 1.1.0-SNAPSHOT (3.10.0.M5)

    Has anyone made any progress on the Xalan issue?

    Nick

    On Mon, Jan 29, 2018 at 2:36 PM, Nick Boldt <[hidden email]> wrote:
      Confirmed. To install this build you need to first add a link to the Jetty 9.4.7 site [1] in your Eclipse.

      [1] http://download.eclipse.org/jetty/updates/jetty-bundles-9.x/9.4.7.v20170914/

      However I'm also seeing remediation trying to install this:

      Cannot complete the install because of a conflicting dependency.
        Software being installed: Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
        Software being installed: Eclipse Web Developer Tools 3.9.2.v201801221842 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201801221842)
        Only one of the following can be installed at once: 
          Server Core 1.10.0.v201711201954 (org.eclipse.wst.server.core 1.10.0.v201711201954)
          Server Core 1.10.0.v201705172051 (org.eclipse.wst.server.core 1.10.0.v201705172051)

      I'll look into WHY we have two versions of that plugin in the repo... we shouldn't have both.



      On Mon, Jan 29, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:
      Folks,

      This was all caused by Nick's fix to bug 527813 , which moved WTP from including the two Jetty plugins that the Platform does not ship, to simply requiring those plugins. BIRT includes the 9.4.5 version of those plugins (yet, the platform, and WTP, moved up to Jetty 9.4.7 for Oxygen.2 and Photon M4). If you look at comment #31 on that bug, you will find the link to the repo that you need to add in order to resolve this dependency during WTP's install.


      Nick,


      Due to issues that have arisen with adopters using Oxygen.2 and everyone using Photon M5, should we revisit the decision to move this from an include to a require? Right now, WTP is at the mercy of other teams like BIRT, which includes the 9.4.5 versions of these Jetty plugins in Photon. The Eclipse Platform does not include all of the Jetty plugins that WTP requires, and there is no direct contribution of the Jetty plugins to the simultaneous release aggregation. From a release engineering standpoint, this is not ideal.


      FWIW,


      - Carl Anderson
      WTP Releng project lead


      Inactive hide details for Robert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's buiRobert Stryker ---01/29/2018 11:46:14 AM---Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case,

      From:
      Robert Stryker <[hidden email]>
      To:
      Webtools releng discussion list <[hidden email]>
      Cc:
      Carl Anderson <[hidden email]>, Nitin Dahyabhai <[hidden email]>, Keith Chong <[hidden email]>, Victor Rubezhny <[hidden email]>
      Date:
      01/29/2018 11:46 AM
      Subject:
      Re: [wtp-releng] Smoke Test Request for WTP 3.10.0 I-build




      Victor and I are both having problems installing wtp's build on a platform m5 (or in victor's case, m4?)

      The issue seems to be that When installing WTP 3.10.M5 smoke test candidate, could not find org.eclipse.jetty.webapp [9.4.7,10.0.0).  Servertools seems to need this library and cannot find it.

      Even though the UI insists it won't install servertools, it still does, but it installs a lower version than expected.

      696    STARTING    org.eclipse.wst.server.core_1.10.0.v201705172051
      697    STARTING    org.eclipse.wst.server.discovery_1.3.100.v201705102053
      698    STARTING    org.eclipse.wst.server.ui_1.5.400.v201705172051
      699    STARTING    org.eclipse.wst.server.ui.doc.user_1.1.600.v201309182117
      700    RESOLVED    org.eclipse.wst.server.ui.infopop_1.1.200.v201309182117

      This is pretty confusing for me. Remediation insisted it would not install it, but it installed it anyway, but somehow found a downgraded version despite using the http://build.eclipse.org/webtools/committers/wtp-R3.10.0-I/20180125000115/I-3.10.0-20180125000115/repository/  update site.

      Very weird behavior

      - Rob


      On Fri, Jan 26, 2018 at 4:44 PM, Nick Boldt <[hidden email]> wrote:
          And now the build is failing because Tycho 1.1.0-SNAPSHOT says:

          [DEBUG] Closing connection to remote
          [ERROR] Failed to execute goal org.eclipse.tycho:tycho-compiler-plugin:1.1.0-SNAPSHOT:compile (default-compile) on project org.eclipse.wst.xsl.xalan: Compilation failure: Compilation failure:
          [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanDebugger.java:[46]
          [ERROR] lastTransformerInChain.getSerializationHandler().flushPending();
          [ERROR]                        ^^^^^^^^^^^^^^^^^^^^^^^
          [ERROR] The method getSerializationHandler() is undefined for the type TransformerImpl
          [ERROR] /jobs/genie.webtools/WTP-R3_10_Integration/workspace/webtools.sourceediting/xsl/bundles/org.eclipse.wst.xsl.xalan/src-debugger/org/eclipse/wst/xsl/xalan/debugger/XalanStyleFrame.java:[131]
          [ERROR] currentLine = e.m_styleNode.getEndLineNumber();
          [ERROR]                             ^^^^^^^^^^^^^^^^
          [ERROR] The method getEndLineNumber() is undefined for the type ElemTemplateElement
          [ERROR] 2 problems (2 errors)


          Back to you in the studio, sourceediting folks.


          https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/237/console



          On Fri, Jan 26, 2018 at 1:52 PM, Nick Boldt <[hidden email]> wrote:
          I pulled in the latest commits from these 4 repos:

          * 0bc38df - (HEAD -> master, origin/master) pull latest from  webtools.javaee webtools.jsdt webtools.jsf webtools.sourceediting [hidden email] (6 minutes ago)

          Build 235 triggered using Tycho 1.1.0-SNAPSHOT and using M5 instead of an I build of Eclipse Platform.

          https://hudson.eclipse.org/webtools/view/webtools_R3_10/job/WTP-R3_10_Integration/235/parameters/


          On Fri, Jan 26, 2018 at 1:45 PM, Carl Anderson <[hidden email]> wrote:



          --
          Nick Boldt
          Senior Software Engineer, RHCSA
          Productization Lead :: JBoss Tools & Dev Studio
          IM: @nickboldt / @nboldt /
          http://nick.divbyzero.com
      TRIED. TESTED. TRUSTED.
      TRIED. TESTED. TRUSTED.





      _______________________________________________
      wtp-releng mailing list
      [hidden email]
      To change your delivery options, retrieve your password, or unsubscribe from this list, visit
      https://dev.eclipse.org/mailman/listinfo/wtp-releng



      --
      Nick Boldt
      Senior Software Engineer, RHCSA
      Productization Lead :: JBoss Tools & Dev Studio
      IM: @nickboldt / @nboldt / http://nick.divbyzero.com
TRIED. TESTED. TRUSTED.

TRIED. TESTED. TRUSTED.



    --
    Nick Boldt
    Senior Software Engineer, RHCSA
    Productization Lead :: JBoss Tools & Dev Studio
    IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.



--
Nick Boldt
Senior Software Engineer, RHCSA
Productization Lead :: JBoss Tools & Dev Studio
IM: @nickboldt / @nboldt / http://nick.divbyzero.com

TRIED. TESTED. TRUSTED.
@ @redhatnews      Red Hat
_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_wtp-2Dreleng&d=DwICAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6JCYBixIS0G6Rj43h5xZSA&m=FWf-wSfe1YZvU55jytAPBda4PkCnpZrdTv2TQl9EGpY&s=1rh4Yx6SqZIXwkN1LJRgeZDdr5E5xq3EJJYUEGvBoGg&e=



_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng



--

Nick Boldt

Senior Software Engineer, RHCSA

Productization Lead :: JBoss Tools & Dev Studio

IM: @nickboldt / @nboldt / http://nick.divbyzero.com


_______________________________________________
wtp-releng mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/wtp-releng