Trouble running... no breakpoints created, etc.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Trouble running... no breakpoints created, etc.

Beth Tibbitts-2
It builds ok...
But now I'm having trouble running...

Exception during launch
no breakpoint created

Console:
++++++++++ orte_server: SVR received <SFB 64:0fffffffffffffffffffffffff 0 "" "main">
++++++++++ orte_server: creating new request for {0-99}
got debug event: EVENT_DBG_OK 0fffffffffffffffffffffffff
<00000003 QUI>
++++++++++ orte_server: SVR received <QUI>
++++++++++ orte_server: SVR reply <0 112 0:0 6 1:00>
AbstractProxyDebugClientgot event EVENT_OK 112 0:0 6 1:00
got debug event: EVENT_DBG_ERROR 0 6
======================= EVENT_DBG_ERROR ====================
----- debugger error:
    --- Abs debugger: org.eclipse.ptp.debug.external.core.cdi.event.ErrorEvent@1b0bf9a
event thread exiting...

Nothing in the .log file
Nothing in Error view of dev. workbench

================= Next try with more detail:

Relaunch ptp debug on my app
Gets to "creating debugging session..." in progress information dialog.
error dialog appears.  Erro: on tasks: 0
Error within Debug UI:
Details button reveals:
   "Error:  on tasks: 0"
Hit ok and Error dialog says:
Exception occurred during launch
Reason: No breakpoint created

The launch config, under Debugger tab, does indeed have the
"Stop at main() on startup"  CHECKED.

Closed PTP debug workbench
run ./cleanupOmpi.sh

Relaunch PTP (again as Run.. not Debug..)
Relaunch PTP debug on my app..

It rebuilt...extraneous keystrokes in src editor forced rebuild .. had error..
closed PTP.  ran cleanup.

Launch PTP again.  Fix src err in my src file.
Set a global breakpoint just in case, on first executable line in src file.
Launch PTP debug on my app again...(with 100 processes)

Did stop on my manually set bkpt.

Made process set of processes 1,2,3,4. Set a set bkpt on line x.
set a global bkpt on line y (y>x)    x=17(MPI_Init)  y=20(MPI_Comm-Rank)
Process 0 and 1 are registered. (one outside the set, one inside the set.)
did Run on up on the Parallel Debug view,
which I assume will stop the set processes on line x,
but all the other processes will go to line y.

But after seeming to hang the UI for a while,
response comes back, but all my processes are green (running)
and I don't see anybody stopping at either breakpoint.

OK now the .log file shows an error, but it was from 20 min ago and i'm not sure if it's this run...
!ENTRY org.eclipse.osgi 2006-02-05 13:59:32.936
!MESSAGE Error while stopping "org.eclipse.debug.ui_3.1.2".
!STACK 0
org.osgi.framework.BundleException: Exception in org.eclipse.debug.internal.ui.DebugUIPlugin.stop() of bundle org.eclipse.debug.ui.
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.stop(BundleContextImpl.java:1051)
    at org.eclipse.osgi.framework.internal.core.BundleHost.stopWorker(BundleHost.java:397)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.stop(AbstractBundle.java:408)
    at org.eclipse.core.runtime.internal.adaptor.BundleStopper.basicStopBundles(BundleStopper.java:82)
    at org.eclipse.core.runtime.internal.adaptor.BundleStopper.stopBundles(BundleStopper.java:72)
    at org.eclipse.core.runtime.adaptor.EclipseAdaptor.frameworkStopping(EclipseAdaptor.java:766)
    at org.eclipse.osgi.framework.internal.core.Framework.shutdown(Framework.java:528)
    at org.eclipse.osgi.framework.internal.core.SystemBundle$1.run(SystemBundle.java:171)
    at java.lang.Thread.run(Thread.java:534)
Caused by: java.lang.NullPointerException
    at org.eclipse.debug.internal.ui.views.breakpoints.BreakpointOrganizerExtension.dispose(BreakpointOrganizerExtension.java:145)
    at org.eclipse.debug.internal.ui.views.breakpoints.BreakpointOrganizerManager.shutdown(BreakpointOrganizerManager.java:152)
    at org.eclipse.debug.internal.ui.DebugUIPlugin.stop(DebugUIPlugin.java:354)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$3.run(BundleContextImpl.java:1035)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.stop(BundleContextImpl.java:1031)
    ... 8 more
Root exception:
java.lang.NullPointerException
    at org.eclipse.debug.internal.ui.views.breakpoints.BreakpointOrganizerExtension.dispose(BreakpointOrganizerExtension.java:145)
    at org.eclipse.debug.internal.ui.views.breakpoints.BreakpointOrganizerManager.shutdown(BreakpointOrganizerManager.java:152)
    at org.eclipse.debug.internal.ui.DebugUIPlugin.stop(DebugUIPlugin.java:354)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$3.run(BundleContextImpl.java:1035)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.stop(BundleContextImpl.java:1031)
    at org.eclipse.osgi.framework.internal.core.BundleHost.stopWorker(BundleHost.java:397)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.stop(AbstractBundle.java:408)
    at org.eclipse.core.runtime.internal.adaptor.BundleStopper.basicStopBundles(BundleStopper.java:82)
    at org.eclipse.core.runtime.internal.adaptor.BundleStopper.stopBundles(BundleStopper.java:72)
    at org.eclipse.core.runtime.adaptor.EclipseAdaptor.frameworkStopping(EclipseAdaptor.java:766)
    at org.eclipse.osgi.framework.internal.core.Framework.shutdown(Framework.java:528)
    at org.eclipse.osgi.framework.internal.core.SystemBundle$1.run(SystemBundle.java:171)
    at java.lang.Thread.run(Thread.java:534)




--
...Beth


_______________________________________________
ptp-dev mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/ptp-dev
Reply | Threaded
Open this post in threaded view
|

Re: Trouble running... no breakpoints created, etc.

Clement Chu-3
Hi Beth,

Beth Tibbitts wrote:

> It builds ok...
> But now I'm having trouble running...
>
> Exception during launch
> no breakpoint created
>
> Console:
> ++++++++++ orte_server: SVR received <SFB
> 64:0fffffffffffffffffffffffff 0 "" "main">
> ++++++++++ orte_server: creating new request for {0-99}
> got debug event: EVENT_DBG_OK 0fffffffffffffffffffffffff
> <00000003 QUI>
> ++++++++++ orte_server: SVR received <QUI>
> ++++++++++ orte_server: SVR reply <0 112 0:0 6 1:00>
> AbstractProxyDebugClientgot event EVENT_OK 112 0:0 6 1:00
> got debug event: EVENT_DBG_ERROR 0 6
> ======================= EVENT_DBG_ERROR ====================
> ----- debugger error:
>     --- Abs debugger:
> org.eclipse.ptp.debug.external.core.cdi.event.ErrorEvent@1b0bf9a
> event thread exiting...
>
This error is from setting main function breakpoint on debugger.  The
error message send to eclipse and then show up the error dialog.  I am
not sure what cause this problem.  Maybe too many processes.  I will
look into this problem.

> Nothing in the .log file
> Nothing in Error view of dev. workbench
>
> ================= Next try with more detail:
>
> Relaunch ptp debug on my app
> Gets to "creating debugging session..." in progress information dialog.
> error dialog appears.  Erro: on tasks: 0
> Error within Debug UI:
> Details button reveals:
>    "Error:  on tasks: 0"
> Hit ok and Error dialog says:
> Exception occurred during launch
> Reason: No breakpoint created
>
> The launch config, under Debugger tab, does indeed have the
> "Stop at main() on startup"  CHECKED.
>
> Closed PTP debug workbench
> run ./cleanupOmpi.sh
>
> Relaunch PTP (again as Run.. not Debug..)
> Relaunch PTP debug on my app..
>
> It rebuilt...extraneous keystrokes in src editor forced rebuild .. had
> error..
> closed PTP.  ran cleanup.
>
> Launch PTP again.  Fix src err in my src file.
> Set a global breakpoint just in case, on first executable line in src
> file.
> Launch PTP debug on my app again...(with 100 processes)
>
> Did stop on my manually set bkpt.
>
> Made process set of processes 1,2,3,4. Set a set bkpt on line x.
> set a global bkpt on line y (y>x)    x=17(MPI_Init)  y=20(MPI_Comm-Rank)
> Process 0 and 1 are registered. (one outside the set, one inside the set.)
> did Run on up on the Parallel Debug view,
> which I assume will stop the set processes on line x,
> but all the other processes will go to line y.
>
> But after seeming to hang the UI for a while,
> response comes back, but all my processes are green (running)
> and I don't see anybody stopping at either breakpoint.
>
The following error is normal becuase it only occurs in linux.  I think
we are using runtime-eclipse to test ptp plugin and some extension
plugins not loaded into eclipse very well.  Then causes this problem.

> OK now the .log file shows an error, but it was from 20 min ago and
> i'm not sure if it's this run...
> !ENTRY org.eclipse.osgi 2006-02-05 13:59:32.936
> !MESSAGE Error while stopping "org.eclipse.debug.ui_3.1.2".
> !STACK 0
> org.osgi.framework.BundleException: Exception in
> org.eclipse.debug.internal.ui.DebugUIPlugin.stop() of bundle
> org.eclipse.debug.ui.
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.stop(BundleContextImpl.java:1051)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.stopWorker(BundleHost.java:397)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.stop(AbstractBundle.java:408)
>     at
> org.eclipse.core.runtime.internal.adaptor.BundleStopper.basicStopBundles(BundleStopper.java:82)
>     at
> org.eclipse.core.runtime.internal.adaptor.BundleStopper.stopBundles(BundleStopper.java:72)
>     at
> org.eclipse.core.runtime.adaptor.EclipseAdaptor.frameworkStopping(EclipseAdaptor.java:766)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.shutdown(Framework.java:528)
>     at
> org.eclipse.osgi.framework.internal.core.SystemBundle$1.run(SystemBundle.java:171)
>     at java.lang.Thread.run(Thread.java:534)
> Caused by: java.lang.NullPointerException
>     at
> org.eclipse.debug.internal.ui.views.breakpoints.BreakpointOrganizerExtension.dispose(BreakpointOrganizerExtension.java:145)
>     at
> org.eclipse.debug.internal.ui.views.breakpoints.BreakpointOrganizerManager.shutdown(BreakpointOrganizerManager.java:152)
>     at
> org.eclipse.debug.internal.ui.DebugUIPlugin.stop(DebugUIPlugin.java:354)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$3.run(BundleContextImpl.java:1035)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.stop(BundleContextImpl.java:1031)
>     ... 8 more
> Root exception:
> java.lang.NullPointerException
>     at
> org.eclipse.debug.internal.ui.views.breakpoints.BreakpointOrganizerExtension.dispose(BreakpointOrganizerExtension.java:145)
>     at
> org.eclipse.debug.internal.ui.views.breakpoints.BreakpointOrganizerManager.shutdown(BreakpointOrganizerManager.java:152)
>     at
> org.eclipse.debug.internal.ui.DebugUIPlugin.stop(DebugUIPlugin.java:354)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl$3.run(BundleContextImpl.java:1035)
>     at java.security.AccessController.doPrivileged(Native Method)
>     at
> org.eclipse.osgi.framework.internal.core.BundleContextImpl.stop(BundleContextImpl.java:1031)
>     at
> org.eclipse.osgi.framework.internal.core.BundleHost.stopWorker(BundleHost.java:397)
>     at
> org.eclipse.osgi.framework.internal.core.AbstractBundle.stop(AbstractBundle.java:408)
>     at
> org.eclipse.core.runtime.internal.adaptor.BundleStopper.basicStopBundles(BundleStopper.java:82)
>     at
> org.eclipse.core.runtime.internal.adaptor.BundleStopper.stopBundles(BundleStopper.java:72)
>     at
> org.eclipse.core.runtime.adaptor.EclipseAdaptor.frameworkStopping(EclipseAdaptor.java:766)
>     at
> org.eclipse.osgi.framework.internal.core.Framework.shutdown(Framework.java:528)
>     at
> org.eclipse.osgi.framework.internal.core.SystemBundle$1.run(SystemBundle.java:171)
>     at java.lang.Thread.run(Thread.java:534)
>
>
>
>
> --
> ...Beth
>
>------------------------------------------------------------------------
>
>_______________________________________________
>ptp-dev mailing list
>[hidden email]
>https://dev.eclipse.org/mailman/listinfo/ptp-dev
>  
>


--
Clement Kam Man Chu
Research Assistant
School of Computer Science & Software Engineering
Monash University, Caulfield Campus
Ph: 61 3 9903 1964

_______________________________________________
ptp-dev mailing list
[hidden email]
https://dev.eclipse.org/mailman/listinfo/ptp-dev