Unable to build Mylyn Docs EPUB bugfix release

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to build Mylyn Docs EPUB bugfix release

Torkild U. Resheim
Hi,

I was wanting to release a new version of the EPUB component in Mylyn Docs, but are suddenly unable to do so due to what appears to be a misconfiguration of the HIPP instance. The build job no longer have access to GPG keys and fails:

[INFO] [INFO] --- maven-gpg-plugin:1.6:sign (sign-artifacts) @ epub.core ---

[INFO] gpg: problem with the agent: End of file
[INFO] gpg: no default secret key: Operation cancelled
[INFO] gpg: signing failed: Operation cancelled


Any ideas on how to resolve this?

Best regards,
Torkild

_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build Mylyn Docs EPUB bugfix release

David Green-15
Torkild,

If this worked before and has stopped working, you should file a bug against Eclipse Foundation/Community/Hudson to get help.

David

On Sun, Jan 14, 2018 at 6:50 AM Torkild U. Resheim <[hidden email]> wrote:
Hi,

I was wanting to release a new version of the EPUB component in Mylyn Docs, but are suddenly unable to do so due to what appears to be a misconfiguration of the HIPP instance. The build job no longer have access to GPG keys and fails:

[INFO] [INFO] --- maven-gpg-plugin:1.6:sign (sign-artifacts) @ epub.core ---

[INFO] gpg: problem with the agent: End of file
[INFO] gpg: no default secret key: Operation cancelled
[INFO] gpg: signing failed: Operation cancelled


Any ideas on how to resolve this?

Best regards,
Torkild
_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev


--


David Green | VP of Architecture Tasktop

email: [hidden email]


_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build Mylyn Docs EPUB bugfix release

Torkild U. Resheim
Thanks David,

I’ve filed https://bugs.eclipse.org/bugs/show_bug.cgi?id=530080.

Best regards,
Torkild

> 15. jan. 2018 kl. 18:35 skrev David Green <[hidden email]>:
>
> Torkild,
>
> If this worked before and has stopped working, you should file a bug against Eclipse Foundation/Community/Hudson to get help.
>
> David
>
> On Sun, Jan 14, 2018 at 6:50 AM Torkild U. Resheim <[hidden email]> wrote:
> Hi,
>
> I was wanting to release a new version of the EPUB component in Mylyn Docs, but are suddenly unable to do so due to what appears to be a misconfiguration of the HIPP instance. The build job no longer have access to GPG keys and fails:
>
> [INFO] [INFO] --- maven-gpg-plugin:1.6:sign (sign-artifacts) @ epub.core ---
>
> [INFO] gpg: problem with the agent: End of file
> [INFO] gpg: no default secret key: Operation cancelled
> [INFO] gpg: signing failed: Operation cancelled
>
>
> Any ideas on how to resolve this?
>
> Best regards,
> Torkild
> _______________________________________________
> mylyn-dev mailing list
> [hidden email]
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
> https://dev.eclipse.org/mailman/listinfo/mylyn-dev
>
>
> --
>
> David Green | VP of Architecture | Tasktop
> email: [hidden email]
> _______________________________________________
> mylyn-dev mailing list
> [hidden email]
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
> https://dev.eclipse.org/mailman/listinfo/mylyn-dev

_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build Mylyn Docs EPUB bugfix release

Torkild U. Resheim
It turns out it was a problem on the HIPP:

"Since January 8th, apache-maven-latest symlink has been changed to point from Maven version 3.3.9 to version 3.5.2 (as announced on cross-project on Dec 14th https://dev.eclipse.org/mhonarc/lists/cross-project-issues-dev/msg15076.html
). It introduces a regression which prevents Hudson to inject custom settings file (with GPG passphrase) into it.

As a workaround, I've created a specific tool configuration for Apache Maven version 3.3.9 (named apache-maven-3.3.9) on your HIPP. I've also changed your job "mylyn-docs-epub-release" use it instead of apache-maven-latest. It should fix your issue. If you have other jobs with the same error, just do the same change.»

The "mylyn-wikitext-release" job should also be to use the apache-maven-3.3.9 tool. I don’t have access to do so.

Best regards,
Torkild

> 20. jan. 2018 kl. 21:47 skrev Torkild U. Resheim <[hidden email]>:
>
> Thanks David,
>
> I’ve filed https://bugs.eclipse.org/bugs/show_bug.cgi?id=530080.
>
> Best regards,
> Torkild
>
>> 15. jan. 2018 kl. 18:35 skrev David Green <[hidden email]>:
>>
>> Torkild,
>>
>> If this worked before and has stopped working, you should file a bug against Eclipse Foundation/Community/Hudson to get help.
>>
>> David
>>
>> On Sun, Jan 14, 2018 at 6:50 AM Torkild U. Resheim <[hidden email]> wrote:
>> Hi,
>>
>> I was wanting to release a new version of the EPUB component in Mylyn Docs, but are suddenly unable to do so due to what appears to be a misconfiguration of the HIPP instance. The build job no longer have access to GPG keys and fails:
>>
>> [INFO] [INFO] --- maven-gpg-plugin:1.6:sign (sign-artifacts) @ epub.core ---
>>
>> [INFO] gpg: problem with the agent: End of file
>> [INFO] gpg: no default secret key: Operation cancelled
>> [INFO] gpg: signing failed: Operation cancelled
>>
>>
>> Any ideas on how to resolve this?
>>
>> Best regards,
>> Torkild
>> _______________________________________________
>> mylyn-dev mailing list
>> [hidden email]
>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>> https://dev.eclipse.org/mailman/listinfo/mylyn-dev
>>
>>
>> --
>>
>> David Green | VP of Architecture | Tasktop
>> email: [hidden email]
>> _______________________________________________
>> mylyn-dev mailing list
>> [hidden email]
>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>> https://dev.eclipse.org/mailman/listinfo/mylyn-dev
>

_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Unable to build Mylyn Docs EPUB bugfix release

David Green-15
Thanks Torkild. 

The build you mention is already configured to use Maven 3.0.5.  We can update the job if it fails on the next release.

David

On Tue, Jan 23, 2018 at 1:51 PM Torkild U. Resheim <[hidden email]> wrote:
It turns out it was a problem on the HIPP:

"Since January 8th, apache-maven-latest symlink has been changed to point from Maven version 3.3.9 to version 3.5.2 (as announced on cross-project on Dec 14th https://dev.eclipse.org/mhonarc/lists/cross-project-issues-dev/msg15076.html
). It introduces a regression which prevents Hudson to inject custom settings file (with GPG passphrase) into it.

As a workaround, I've created a specific tool configuration for Apache Maven version 3.3.9 (named apache-maven-3.3.9) on your HIPP. I've also changed your job "mylyn-docs-epub-release" use it instead of apache-maven-latest. It should fix your issue. If you have other jobs with the same error, just do the same change.»

The "mylyn-wikitext-release" job should also be to use the apache-maven-3.3.9 tool. I don’t have access to do so.

Best regards,
Torkild

> 20. jan. 2018 kl. 21:47 skrev Torkild U. Resheim <[hidden email]>:
>
> Thanks David,
>
> I’ve filed https://bugs.eclipse.org/bugs/show_bug.cgi?id=530080.
>
> Best regards,
> Torkild
>
>> 15. jan. 2018 kl. 18:35 skrev David Green <[hidden email]>:
>>
>> Torkild,
>>
>> If this worked before and has stopped working, you should file a bug against Eclipse Foundation/Community/Hudson to get help.
>>
>> David
>>
>> On Sun, Jan 14, 2018 at 6:50 AM Torkild U. Resheim <[hidden email]> wrote:
>> Hi,
>>
>> I was wanting to release a new version of the EPUB component in Mylyn Docs, but are suddenly unable to do so due to what appears to be a misconfiguration of the HIPP instance. The build job no longer have access to GPG keys and fails:
>>
>> [INFO] [INFO] --- maven-gpg-plugin:1.6:sign (sign-artifacts) @ epub.core ---
>>
>> [INFO] gpg: problem with the agent: End of file
>> [INFO] gpg: no default secret key: Operation cancelled
>> [INFO] gpg: signing failed: Operation cancelled
>>
>>
>> Any ideas on how to resolve this?
>>
>> Best regards,
>> Torkild
>> _______________________________________________
>> mylyn-dev mailing list
>> [hidden email]
>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>> https://dev.eclipse.org/mailman/listinfo/mylyn-dev
>>
>>
>> --
>>
>> David Green | VP of Architecture | Tasktop
>> email: [hidden email]
>> _______________________________________________
>> mylyn-dev mailing list
>> [hidden email]
>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>> https://dev.eclipse.org/mailman/listinfo/mylyn-dev
>

_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev


--


David Green | VP of Architecture Tasktop

email: [hidden email]


_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev