Quantcast

Updating the version of a connector in tasks repositories

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Updating the version of a connector in tasks repositories

Patrick Pollo Guilbert
Hi mylyn-dev,

Sorry if this is the wrong mailing list, but I didn't know where to post
that question.

When using the tasks repositories and adding a new task repository, it
opens the NewRepositoryWizard, and there you can install some more
connectors. I recently picked up the development of the Tuleap Mylyn
Connector for eclipse and I updated the version to 2.3 on the
marketplace, but using the wizard from ConnectorDiscoveryWizard, the old
2.2 build is still shown. How do I change that? Do I need to submit a
patch for mylyn, open a bugzilla pointing to the new update site etc.

Any informations would be helpful,

Thanks!

Patrick

_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Updating the version of a connector in tasks repositories

Colin Ritchie
Hi Patrick,

This is good channel for these questions, and thank you for pointing out the issue.  It would be very helpful if you could contribute the fix, and would allow you to fix these in the future.  

Here is an example of the code change of versions for discovery: 

Please reach out if you have more questions.
Colin

On Thu, Oct 13, 2016 at 7:52 AM, Patrick Pollo Guilbert <[hidden email]> wrote:
Hi mylyn-dev,

Sorry if this is the wrong mailing list, but I didn't know where to post that question.

When using the tasks repositories and adding a new task repository, it opens the NewRepositoryWizard, and there you can install some more connectors. I recently picked up the development of the Tuleap Mylyn Connector for eclipse and I updated the version to 2.3 on the marketplace, but using the wizard from ConnectorDiscoveryWizard, the old 2.2 build is still shown. How do I change that? Do I need to submit a patch for mylyn, open a bugzilla pointing to the new update site etc.

Any informations would be helpful,

Thanks!

Patrick

_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev



--
Colin Ritchie | Engineering Manager | Tasktop Technologies  

_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Updating the version of a connector in tasks repositories

Patrick Pollo Guilbert

Hi Colin,

I was almost getting there by bisecting how the wizard page got its connectors, but thank you for saving me time! I'll try and submit a patch soon enough.

Patrick

On 10/13/2016 04:22 PM, Colin Ritchie wrote:
Hi Patrick,

This is good channel for these questions, and thank you for pointing out the issue.  It would be very helpful if you could contribute the fix, and would allow you to fix these in the future.  

Here is an example of the code change of versions for discovery: 

Please reach out if you have more questions.
Colin

On Thu, Oct 13, 2016 at 7:52 AM, Patrick Pollo Guilbert <[hidden email]> wrote:
Hi mylyn-dev,

Sorry if this is the wrong mailing list, but I didn't know where to post that question.

When using the tasks repositories and adding a new task repository, it opens the NewRepositoryWizard, and there you can install some more connectors. I recently picked up the development of the Tuleap Mylyn Connector for eclipse and I updated the version to 2.3 on the marketplace, but using the wizard from ConnectorDiscoveryWizard, the old 2.2 build is still shown. How do I change that? Do I need to submit a patch for mylyn, open a bugzilla pointing to the new update site etc.

Any informations would be helpful,

Thanks!

Patrick

_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev



--
Colin Ritchie | Engineering Manager | Tasktop Technologies  


_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev


_______________________________________________
mylyn-dev mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/mylyn-dev
Loading...